Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Development and Darwin (http://www.mac-forums.com/forums/os-x-development-darwin/)
-   -   xcode build help (http://www.mac-forums.com/forums/os-x-development-darwin/97581-xcode-build-help.html)

universible 02-20-2008 11:32 AM

xcode build help
 
I am completely out of my league with xcode, but I am trying to compile mp3val http://mp3val.sourceforge.net/ to save me from hours and hours of reripping my CD collection after a HDD crash (my backup of my MP3s apparently got messed up because all my files seem to have sync errors, skip and pop)....anywho....

I figured out how to start a new C++ project in xcode, and thought I figured out how to add the program files for mp3val...when I try and build the program I get some sort of error:

Quote:

cd /Users/t_k/test
/Developer/usr/bin/g++-4.0 -o /Users/t_k/test/build/test.build/Release/test.build/Objects-normal/ppc/test -L/Users/t_k/test/build/Release -F/Users/t_k/test/build/Release -filelist /Users/t_k/test/build/test.build/Release/test.build/Objects-normal/ppc/test.LinkFileList -framework Carbon -arch ppc -mmacosx-version-min=10.5 -Wl,-dead_strip -no_dead_strip_inits_and_terms -isysroot /Developer/SDKs/MacOSX10.5.sdk
ld: duplicate symbol _main in /Users/t_k/test/build/test.build/Release/test.build/Objects-normal/ppc/main-8A88286D.o and /Users/t_k/test/build/test.build/Release/test.build/Objects-normal/ppc/main-A07497A6.o

collect2: ld returned 1 exit status
I have no idea if I am starting out on this all wrong or what. Anyone have an suggestions on how to fix it?

Thanks!

universible 02-22-2008 03:03 AM

Anyone? I still can't figure it out...

xstep 02-22-2008 04:49 AM

I downloaded the generic command line version of the project, unzipped it, renamed the Makefile.cpp to just Makefile, and typed make to build it. This gave me the mp3val.exe executable file.

I have no idea if this is the proper way, but, to bring it into Xcode (version 3), I created a project as a C++ Tool under the Command Line Utility selection. I first removed the main.ccp file that was created by default in the Source folder, then dragged all of the .cpp & .h files into the Source folder (use the copy if needed option), then hit build. Note that I had to make the new project name mp3val. I tried a different name I got 19 errors during compiling.

universible 02-22-2008 10:05 PM

Thanks for the help! That worked for the build. I tried the program and it starts to analyze the first file and then gives: "segmentation fault"

Any ideas?

xstep 02-23-2008 04:25 AM

Nope. Don't know.

I'd test it on a known good rip. So rip a CD and pass those files to it. If that works then perhaps your corrupted files are really messed up.


All times are GMT -4. The time now is 06:05 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.