New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

Mac 10.4: Launchd Problem


Post Reply New Thread Subscribe

 
Thread Tools
Pankaj

 
Member Since: Feb 18, 2008
Posts: 3
Pankaj is on a distinguished road

Pankaj is offline
Hi,

I am trying to run more than one programs through single .plist using launchd.
I don't know how to put program arguments. I have tried for that but not getting results. I am new user of Mac 10.4

My .plist format is:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>com.domain.Agent</string>
<key>OnDemand</key>
<false/>
<key>ProgramArguments</key>
<array>
<string>/usr/local/prgram1</string>
<string>/usr/local/prgram2</string>
</array>
<key>RunAtLoad</key>
<true/>
<key>StandardErrorPath</key>
<string>/Library/Logs/Prg.log</string>
<key>StandardOutPath</key>
<string>/Library/Logs/Prg.log</string>
</dict>
</plist>


Plz help on this..

Thanks,
Pankaj.
QUOTE Thanks

Post Reply New Thread Subscribe


« How to run more than one programs in single plist through launchd | Terminal Commands »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Mac Keyboard KVM problem JeffBookPro Other Hardware and Peripherals 3 05-06-2011 08:01 PM
Problem with switching from Mac to Windows Burtonhits3005 Running Windows (or anything else) on your Mac 2 07-09-2007 12:13 AM
Disillusioned Mac desigener switches to Windows mogwai Schweb's Lounge 21 05-11-2006 02:05 PM
Mac mini DVI to HDMI Output Problem DaMackMini Apple Desktops 3 04-15-2005 04:27 PM
Mac Users Get More ISP Choices schweb Apple Rumors and Reports 1 03-06-2003 10:57 AM

All times are GMT -4. The time now is 04:23 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?