Results 1 to 7 of 7
  1. #1


    Member Since
    Nov 18, 2007
    Posts
    2
    eclipse does not run in leopard?
    Hi,
    I am new in using Mac OS, I just bought a mac pro. I use eclipse a lot for C++ programming. I just downloaded Eclipse IDE for C/C++ Developers, and after decompressing the file, I tried to run the Eclipse.app, and it doesn't do anything, I don't even see it running in the Activity Monitor.

    Is there anything that should be configured?; according to the eclipse readme file, It should be pretty much just copying the Eclipse folder into the Applications folder, and executing the file.

    Any input as how to fix it will be greatly appreciated.

    thanks

    Adan

  2. #2


    Member Since
    Oct 27, 2005
    Posts
    4,702
    If you need a stop-gap you could try this:

    Intellij

    I found this tidbit on my travels:

    As predicted, Eclipse on 64-bit Java in Leopard runs afoul of SWT/Carbon incompatibility. However, Leopard provides both 32-bit and 64-bit JavaVMs (and launches the 32-bit VM by default), so Eclipse runs just fine.

  3. #3


    Member Since
    Dec 24, 2006
    Location
    N. Ireland
    Posts
    901
    Specs:
    Mac Pro 2xQuad core 2.8GHZ
    Eclipse works for me and I am running Leopard - mind you i develop in Java not C++, but that shouldnt make a difference

  4. #4


    Member Since
    Nov 18, 2007
    Posts
    2
    I found this in the console log

    19/11/07 9:57:05 AM com.apple.launchd[66] ([0x0-0x2a02a].org.eclipse.eclipse[231]) posix_spawnp("/Users/acosgaya/Downloads/eclipse-cpp-europa-fall2-macosx-carbon/eclipse/Eclipse.app/Contents/MacOS/eclipse", ...): Permission denied
    19/11/07 9:57:05 AM com.apple.launchd[66] ([0x0-0x2a02a].org.eclipse.eclipse[231]) Exited with exit code: 1
    19/11/07 9:57:09 AM com.apple.launchd[66] (com.apple.FolderActions.enabled[227]) Exited: Terminated

    It seems I have to give some sort of permission. How could I do this?

    thanks

  5. #5

    Richie_Gecko's Avatar
    Member Since
    Sep 22, 2005
    Location
    Las Vegas, NV
    Posts
    206
    Specs:
    13" MacBook Pro
    That is very strange. I am running Eclipse Europa (3.3.1.1) in Leopard without any issues.
    Mac: White MacBook; 2.0 Core Duo; 2GB RAM; 100GB 7200 RPM; 20" Cinema Display
    PC: 64 x2 Dual Core 5200+, 2 GB RAM, 320GB 7200RPM SATA, GeForce 7600GT 128MB
    Car: 2008 Toyota Prius w/ Lots of Goodies
    On the Internets: Flickr | My Site

  6. #6


    Member Since
    Nov 20, 2007
    Location
    Dublin, Ireland
    Posts
    9
    Quote Originally Posted by acosgaya View Post
    I found this in the console log

    19/11/07 9:57:05 AM com.apple.launchd[66] ([0x0-0x2a02a].org.eclipse.eclipse[231]) posix_spawnp("/Users/acosgaya/Downloads/eclipse-cpp-europa-fall2-macosx-carbon/eclipse/Eclipse.app/Contents/MacOS/eclipse", ...): Permission denied
    19/11/07 9:57:05 AM com.apple.launchd[66] ([0x0-0x2a02a].org.eclipse.eclipse[231]) Exited with exit code: 1
    19/11/07 9:57:09 AM com.apple.launchd[66] (com.apple.FolderActions.enabled[227]) Exited: Terminated

    It seems I have to give some sort of permission. How could I do this?

    thanks
    Not sure, but you might try "sudo chmod a+x /Users/acosgaya/Downloads/eclipse-cpp-europa-fall2-macosx-carbon/eclipse/Eclipse.app/Contents/MacOS/eclipse" in case it's for some reason not executable? Maybe the archive extracted without preserving permissions.

  7. #7


    Member Since
    Jan 21, 2008
    Posts
    1
    my eclipse doesnt work either
    So its proven.
    I was running eclipse on my Mac with OS 10.4.
    and I was running c++ and java programs with no problems. I could develop in both languages
    I then installed Leopard. Java still works. No problems at all. But i have problems with compiling the C++ projects i had previously. Not even Hello world works


    /usr/lib/gcc/i686-apple-darwin8/4.0.1/../../../libSystem.dylib unknown flags (type) of section 6 (__TEXT,__dof_plockstat) in load command 0

    /usr/lib/gcc/i686-apple-darwin8/4.0.1/libstdc++.dylib load command 8 unknown cmd field

    /usr/lib/libSystem.B.dylib unknown flags (type) of section 6 (__TEXT,__dof_plockstat) in load command 0

    make: *** [RandomPeject]

    (RandomPeject is the name of my project)

    I dont have any solutions to this

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can you run Leopard on a G4 powermac?
    By igeoff in forum OS X - Operating System
    Replies: 7
    Last Post: 06-03-2008, 10:13 AM
  2. Leopard, will it run?
    By Macawhata in forum OS X - Operating System
    Replies: 7
    Last Post: 03-06-2008, 08:04 PM
  3. Will my G3 run 10.5 Leopard
    By justmehere in forum OS X - Operating System
    Replies: 8
    Last Post: 02-07-2008, 04:29 PM
  4. Will Leopard run well on my machine?
    By Thorax_impales in forum OS X - Operating System
    Replies: 2
    Last Post: 10-28-2007, 12:02 AM
  5. Will Leopard run on a g4 powermac
    By JeffBookPro in forum OS X - Operating System
    Replies: 0
    Last Post: 08-13-2007, 05:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •