Results 1 to 4 of 4

Thread: /home mystery

  1. #1

    Member Since
    Nov 03, 2007
    /home mystery
    When I was running Tiger, I created a /home directory, and put some important symbolic links in it. When I upgraded to Leopard, my links had disappeared, and I could no longer write to the apparently empty /home. Its permissions had become:

    dr-xr-xr-x 2 root wheel

    So I added write permissions to make it drwxdrwxdrwx. But for some reason, I still couldn't write to it.

    I tried becoming root with su before writing to it. I tried sudoing as I wrote to it (after adding myself to the wheel group). No matter what I tried, I still couldn't write to it. Whenever I try to create a file or symbolic link in /home, I get an "Input/output error". Curiously, when I reboot, it reverts to its old permissions (dr-xr-xr-x). But even after I change the permissions so I should be able to write to it, I can't. If I delete the directory (via Target Disk Mode), it's automatically regenerated the next time I reboot, and it's still untouchable.

    Can anyone help me figure out how to write to this friggin' directory?

  2. #2

    rman's Avatar
    Member Since
    Dec 24, 2002
    Los Angeles, California
    2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi
    I know the directory/folder does not exist on my system which has tiger installed.

    What I am wondering is has it been created or is it part of the leopard install. Since it is created after you delete it and reboot. You will need a person woth leopard installed to check and see if the /home directory/folder does exist.
    Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!

  3. #3

    Member Since
    Nov 03, 2007
    I think this is a Leopard issue. I looked at another Leopard computer, and it had an untouchable empty "/home" directory as well. Tiger and Panther computers don't seem to have one. Now if I could only figure out how Leopard is locking down this directory, which it isn't even using.

  4. #4

    Member Since
    Nov 03, 2007
    FYI, I got a good answer on the darwin-userlevel mailing list:

    Leopard's automounter uses the path /home for the autofs filesystem. This is where NFS and other network filesystems are mounted. Your original contents are there, but obscured by the mountpoint:

    $ df | grep /home
    map auto_home 0 0 0 100% /home

    See the automount(8) man page for more information about the automounter.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A Mystery
    By mickibob in forum Images, Graphic Design, and Digital Photography
    Replies: 3
    Last Post: 08-12-2014, 05:39 PM
  2. All Images mystery..
    By laiste in forum Images, Graphic Design, and Digital Photography
    Replies: 5
    Last Post: 12-15-2010, 05:17 AM
  3. SSD Mystery
    By merkat106 in forum Apple Notebooks
    Replies: 2
    Last Post: 09-24-2010, 11:18 PM
  4. the mystery emails
    By zygote7 in forum OS X - Operating System
    Replies: 6
    Last Post: 05-07-2009, 08:07 PM
  5. Mystery Shared PC
    By Shark Trager in forum OS X - Operating System
    Replies: 5
    Last Post: 11-28-2007, 07:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts