Results 1 to 2 of 2
  1. #1

    Member Since
    May 24, 2007
    /usr/bin/ld: Undefined symbols
    I'm trying to compile a program that compiles perfectly on my new macbook but gives me the following message when I compile it on my one year old mac mini:

    /usr/bin/ld: Undefined symbols:
    collect2: ld returned 1 exit status
    make: *** [testSWBSCZ] Error 1

    Any ideas of why i'm getting this message?

  2. #2

    rman's Avatar
    Member Since
    Dec 24, 2002
    Los Angeles, California
    2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi
    What that is telling you is that a sub routine is missing (dso handle). You are missing some of the compiler libraries on the mini mac. Make sure you have all of the development environment on your mac nin as you do on your macbook.
    Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Undefined symbols _main
    By polyfrag in forum OS X - Development and Darwin
    Replies: 1
    Last Post: 07-28-2013, 02:52 AM
  2. /usr/bin/defaults has vanished
    By thecommexokid in forum OS X - Operating System
    Replies: 3
    Last Post: 02-10-2013, 01:09 PM
  3. Where to find usr/bin/etc. in finder
    By urbaneast in forum Switcher Hangout
    Replies: 22
    Last Post: 01-04-2013, 06:19 PM
  4. Undefined symbols for architecture x86_64: error on Xcode
    By Bubbagump00 in forum OS X - Development and Darwin
    Replies: 2
    Last Post: 03-22-2012, 12:32 PM
  5. -macosx_version_min,10.5 & Undefined symbols __Unwind_Resume
    By colinhercus in forum OS X - Development and Darwin
    Replies: 0
    Last Post: 01-27-2010, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts