Results 1 to 6 of 6
  1. #1
    Xcode doesn't run application correctly
    Two questions:
    1) Xcode started to not run my app correctly. It builds fine, and it run fine if I run the application directly from the finder, out of the build directory. But for some reason, when I try to run the app or debug the app through xcode, strange things happen. First, the application's icon doesn't appear in the dock, like it normally does. It starts up in the background, and I can't switch to it. If I try to click on it, it doesn't become active. The only click that works on it is to press the close button on the window. Xcode works properly for other applications I'm working on. It used to work fine for this one, but one day it stopped working -- this might be a configuration problem.

    2) When I changed the name of my project directory, I got an error: path/libstdc++_ZeroLink.dylib (No such file or directory, errno = 2)
    The problem was that the path to this library had changed when I changed the directory name. I had to change it back to get it to work. How do I make the path to this library dynamic, or just change it at all?

    Thanks a lot for any help.

  2. #2
    Forget part 2, I figured that out. Part 1 still stands...

  3. #3

    witeshark's Avatar
    Member Since
    Mar 09, 2004
    Miami FL
    G4 1Ghz OS X 10.4.7
    Some apps will run rightly only from the Finder > Applications directory. :rolleyes: I guess it's about having only some directories as application paths Does that help?

  4. #4
    I finally solved this problem and the solution was almost too ridiculous to post. The problem was, believe it or not, the difference in the case of only two characters of the CFBundleName of the application in the Info.plist file. If you change it, your app won't run correctly thru Xcode (at least for me), so I wouldn't recommend touching it. I think it's because there was a case-sensitive difference between the name of the project which Xcode had stored somewhere else, and the CFBundleName.

  5. #5

    rman's Avatar
    Member Since
    Dec 24, 2002
    Los Angeles, California
    2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi
    You learned a very valuable lesson. Unix is case sensitive, when you are working in the command line (terminal).
    Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!

  6. #6
    A correction: the problem with case sensitivity was in CFBundleExecutable, not CFBundleName (the former is defined in Info.plist, the latter in InfoPlist.strings). I thought this is a bug in Xcode, because the app will run fine from the finder, however the same thing happened when trying to run the app thru gdb from the terminal.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Drag and Drop doesn't function correctly
    By operageek in forum OS X - Operating System
    Replies: 5
    Last Post: 06-15-2015, 02:29 PM
  2. Xcode iPhone simluator 6 / 6 Plus not functioning correctly
    By Back Door Daddy in forum iOS Development
    Replies: 0
    Last Post: 03-31-2015, 05:16 PM
  3. Xcode stopped letting me run Xcode app on iPad
    By ildsarria in forum iOS Development
    Replies: 1
    Last Post: 11-09-2011, 03:15 PM
  4. Mac doesn't work correctly
    By Octopustea in forum OS X - Operating System
    Replies: 2
    Last Post: 09-02-2010, 04:49 PM
  5. Safari doesn't display some pages correctly
    By Kola in forum Switcher Hangout
    Replies: 11
    Last Post: 09-17-2009, 04:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts