New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

CGI Scripts


Post Reply New Thread Subscribe

 
Thread Tools
danimal

 
Member Since: Nov 22, 2006
Posts: 33
danimal is on a distinguished road

danimal is offline
Hi all,

I setup my httpd.conf file following the directions on this site:

http://www.cgi101.com/book/connect/mac.html

I am able to view .html pages hosted in my "Sites" directory, but I can't view .pl or .cgi files.
When I try to open a .pl file in my web browser, it says "Forbidden. You don't have permission to access /~hsujd/printenv.pl on this server."
I checked the permissions of my .pl file, and it is world executable.
I checked the apache error log, and it says that "Options ExecCGI is off in this directory: /Users/hsujd/Sites/printenv.pl"
In my httpd.conf file, I have the line "Options MultiViews Indexes SymLinksIfOwnerMatch Includes ExecCGI"

Could someone please help me?

Thanks,
Dan
QUOTE Thanks
novicew

 
novicew's Avatar
 
Member Since: Jan 04, 2006
Location: Hamburg, Germany
Posts: 1,385
novicew is a name known to allnovicew is a name known to allnovicew is a name known to allnovicew is a name known to allnovicew is a name known to allnovicew is a name known to allnovicew is a name known to all
Mac Specs: MacBook Pro | iMac(2.1 G5) | MacBook(2.16 C2D) | MacMini (1.67 CD) | iPhone 4 | iPad (3rd Gen)

novicew is offline
Did you check whether the CGI module in active in /etc/httpd/httpd.conf ? Just in case

LoadModule cgi_module libexec/httpd/mod_cgi.so
QUOTE Thanks
danimal

 
Member Since: Nov 22, 2006
Posts: 33
danimal is on a distinguished road

danimal is offline
Yes, this module is active, but thanks I was unaware of it.

Quote:
Originally Posted by novicew View Post
Did you check whether the CGI module in active in /etc/httpd/httpd.conf ? Just in case

LoadModule cgi_module libexec/httpd/mod_cgi.so
QUOTE Thanks

Post Reply New Thread Subscribe


« am I ready? | need opinion about my app »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Enabling Perl CGI Scripts danimal Web Design and Hosting 1 12-04-2006 04:19 PM
Database calendar, scripts, UI, Dreamhost... surfwax95 Web Design and Hosting 2 09-28-2006 05:16 PM
Apple's iTunes scripts.... farmcock iPod Hardware and Accessories 2 05-17-2006 01:19 PM
Automator Scripts for music and sound etc randomfactor Music, Audio, and Podcasting 2 01-23-2006 12:57 PM
Overnight Maintenance Scripts Question ezhangin Switcher Hangout 1 07-25-2005 12:11 PM

All times are GMT -4. The time now is 08:43 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?