Results 1 to 4 of 4
  1. #1

    Member Since
    Jan 24, 2006
    Pendleton, SC
    iMac Intel 2.0Ghz 17"
    A vexing problem...
    ...that someone can probably fix very easily. Just not me. Here's the rundown.

    I am trying to do what is described in this tutorial . I've installed DarwinPorts but am stuck and installing the Esound Daemon. Here's what I get when I try to install:

    ---> Configuring audiofile
    Error: Target returned: configure failure: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwi nports.org_dpupdate_dports_audio_audiofile/work/audiofile-0.2.6" && ./configure --prefix=/opt/local" returned error 1
    Command output: checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... no
    checking for nawk... no
    checking for awk... awk
    checking whether make sets ${MAKE}... yes
    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable C compiler found in $PATH

    Error: The following dependencies failed to build: audiofile automake autoconf libtool
    Error: /opt/local/bin/port: Status 1 encountered during processing.

    I checked some other forums & sites and found that I might not have Developer Tools installed. So I installed the pkg files Applications/Installers/Xcode Tools/Packages - Developer Tools and, when that didn't seem to work, gcc4.0.

    But I still get that same error. It's like the installations didn't take. I can't get the terminal to recognize GCC anywhere.

    I'm using 10.4, have temporarily granted my user account administrative rights (in order to use sudo), and have only installed (thus far) DarwinPorts, DeveloperTools.pkg, and gcc4.0.pkg.

    This is driving me bonkers....someone please help. For the record, my Unix experience is highly limited. (I know enough to get this tutorial done, or so I thought, until this problem popped up.)

  2. #2

    Member Since
    May 27, 2006
    Concord, NC
    Macbook Pro 17" 2.6GHz 4GB RAM
    If you go under your root directory, do you see a folder called Developer and then Applications under that?

  3. #3

    Member Since
    Jan 24, 2006
    Pendleton, SC
    iMac Intel 2.0Ghz 17"
    I see it. Several folders, Interface Builder, and XCode.

  4. #4

    cradom's Avatar
    Member Since
    Feb 14, 2004
    Groves, Texas
    13in macbook - 10.11 --- 21in. iMac 10.11 --- HP win 8
    If you downloaded Xcode, use the main installer on the .dmg. Don't try to install each package separately. This way you get all the libraries, the X11 SDK, and everything else needed to compile from DarwinPorts and/or Fink. You need to install everything except maybe WebObjects.
    Craig Domingue
    (='.'=) This is Bunny. Copy and paste Bunny into your
    (")_(") signature to help him gain world domination

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. outlook 2011 problem problem problem
    By knfall97 in forum OS X - Apps and Games
    Replies: 0
    Last Post: 03-13-2011, 12:16 AM
  2. Replies: 4
    Last Post: 12-31-2010, 05:19 PM
  3. Replies: 0
    Last Post: 03-08-2010, 08:13 PM
  4. Replies: 7
    Last Post: 09-01-2008, 10:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts