New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

XCode build hangs?


Post Reply New Thread Subscribe

 
Thread Tools
robin
Guest
 
Posts: n/a

I've just started playing around with XCode and have run into a few problems. I have a simple BSD static library project with C++ source files. When a build fails due to source file errors XCode seems to hang as though the build process hasn't ended. Although the application still responds I cannot initiate another build or terminate the current one.

What gives?
QUOTE Thanks
Sean
Guest
 
Posts: n/a

Quote:
Originally Posted by robin
I've just started playing around with XCode and have run into a few problems. I have a simple BSD static library project with C++ source files. When a build fails due to source file errors XCode seems to hang as though the build process hasn't ended. Although the application still responds I cannot initiate another build or terminate the current one.

What gives?
I have just started having the same problem. The only way I have found out of it is to quit xcode and then reenter. I'm using 10.3.2 xcode 1.1 on a 1gb tibook667. Anyone else having the same problem?
QUOTE Thanks
Sean
Guest
 
Posts: n/a

Uhhh - scratch that last post. It appears that I had a mismatch between a nib file in interface builder and its corresponding .h file in xcode. When I fixed that (by dragging the .h file onto the nib window) it all worked fine again. So check out your object declarations.
QUOTE Thanks
Graphite

 
Graphite's Avatar
 
Member Since: Feb 25, 2003
Location: Tropical Island, Jealous?
Posts: 5,279
Graphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud ofGraphite has much to be proud of
Mac Specs: MacPro 3.0Ghz 16GB RAM, 4x256 Vid, 30''cinema display

Graphite is offline
hmm.. I hvnt had that problem yet.. and ive been using it since xCode was released.. :hmm: no idea. Sean seems like he knows whats up though.
QUOTE Thanks

Post Reply New Thread Subscribe


« Enabling PHP in Mac OS 10.2 | Print problems in OS 10.3 »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Xcode Issues with C/C++ Compilation jebradfo OS X - Development and Darwin 2 12-19-2003 03:29 PM
New Xcode plug-in helps developers reuse code Murlyn OS X - Development and Darwin 0 11-10-2003 12:16 PM
Xcode developer tools updated Murlyn OS X - Development and Darwin 0 11-04-2003 05:09 PM
Updated Panther Build Seeded schweb Apple Rumors and Reports 3 07-31-2003 11:47 AM
iChat AV build 112 being tested schweb Apple Rumors and Reports 0 07-25-2003 05:44 PM

All times are GMT -4. The time now is 09:15 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?