New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

Undefined symbols _main


Post Reply New Thread Subscribe

 
Thread Tools
polyfrag

 
Member Since: Jul 28, 2013
Posts: 4
polyfrag is on a distinguished road

polyfrag is offline
I'm trying to make an OpenGL command-line application following the NeHe tutorials.

I defined main(...) in wemain.mm but it says the symbol is undefined. Why isn't it compiling that file? When I put it in wecontroller.mm it read it but then it said NSApplicationMain was undefined that I was calling from main(...).
QUOTE Thanks
polyfrag

 
Member Since: Jul 28, 2013
Posts: 4
polyfrag is on a distinguished road

polyfrag is offline
Oh, I had to add the files to Compile Sources in Build Phases.
QUOTE Thanks

Post Reply New Thread Subscribe


« how to insert variable's value? | weird purple, mirrored, shadow reflections in Xcode's xib editor »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Undefined symbols for architecture x86_64: error on Xcode Bubbagump00 OS X - Development and Darwin 2 03-22-2012 12:32 PM
-macosx_version_min,10.5 & Undefined symbols __Unwind_Resume colinhercus OS X - Development and Darwin 0 01-27-2010 11:10 PM
MS Word symbols from "Insert Symbol" just blank boxes jman995x OS X - Apps and Games 0 07-12-2009 03:57 PM
/usr/bin/ld: Undefined symbols kipepeo OS X - Development and Darwin 1 05-24-2007 07:52 PM

All times are GMT -4. The time now is 08:37 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?