New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

getglobalpolicy in MAC OSX 11 is not returning all the values


Post Reply New Thread Subscribe

 
Thread Tools
thekkayiljoy

 
Member Since: Feb 01, 2013
Posts: 3
thekkayiljoy is on a distinguished road

thekkayiljoy is offline
If i do uname -r it gives:
11.0.0

Now if i try to set a global policy like this:

pwpolicy -n /Local/Default -setglobalpolicy "usingHistory=0 canModifyPasswordforSelf=1 usingExpirationDate=0 usingHardExpirationDate=0 requiresAlpha=0 requiresNumeric=0 maxMinutesUntilChangePassword=0 maxMinutesUntilDisabled=0 maxMinutesOfNonUse=0 maxFailedLoginAttempts=0 minChars=0 maxChars=0 passwordCannotBeName=0 requiresMixedCase=0 requiresSymbol=0 newPasswordRequired=0 minutesUntilFailedLoginReset=0 notGuessablePattern=0"

It shows as if it is successful.

But when i run the following command then only few are listed.:
/usr/bin/pwpolicy -n /Local/Default -getglobalpolicy

maxChars=0 minutesUntilFailedLoginReset=0 maxFailedLoginAttempts=0 minChars=0 requiresNumeric=0 maxMinutesUntilChangePassword=0 requiresAlpha=0 requiresSymbol=0
Now if i try only for "usingHistory=1"

pwpolicy -n /Local/Default -setglobalpolicy "usingHistory=1"

and run the getglobalpolicy then this "usingHistory" is not at all visible.

Now if i run the above commands in OSX 9.4.0 then i can see all the above parameters.

Can you please let me know what is wrong with the above statements.
QUOTE Thanks

Post Reply New Thread Subscribe


« Reference getting lost for a view / Retain count becoming 0 abruptly - xcode | Importing SDK containing library »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Error message what's it mean? lkampouris OS X - Operating System 5 01-30-2013 11:49 AM
Can I delete Mac OSX partition for reinstall OSX again jasonli OS X - Operating System 1 06-13-2011 05:01 PM
My experiences of Mac & OSX miso Switcher Hangout 5 08-09-2007 03:41 PM
Mac Users Get More ISP Choices schweb Apple Rumors and Reports 1 03-06-2003 11:57 AM

All times are GMT -4. The time now is 07:03 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?