Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Development and Darwin (http://www.mac-forums.com/forums/os-x-development-darwin/)
-   -   getglobalpolicy in MAC OSX 11 is not returning all the values (http://www.mac-forums.com/forums/os-x-development-darwin/294393-getglobalpolicy-mac-osx-11-not-returning-all-values.html)

thekkayiljoy 02-01-2013 04:34 AM

getglobalpolicy in MAC OSX 11 is not returning all the values
 
If i do uname -r it gives:
11.0.0

Now if i try to set a global policy like this:

pwpolicy -n /Local/Default -setglobalpolicy "usingHistory=0 canModifyPasswordforSelf=1 usingExpirationDate=0 usingHardExpirationDate=0 requiresAlpha=0 requiresNumeric=0 maxMinutesUntilChangePassword=0 maxMinutesUntilDisabled=0 maxMinutesOfNonUse=0 maxFailedLoginAttempts=0 minChars=0 maxChars=0 passwordCannotBeName=0 requiresMixedCase=0 requiresSymbol=0 newPasswordRequired=0 minutesUntilFailedLoginReset=0 notGuessablePattern=0"

It shows as if it is successful.

But when i run the following command then only few are listed.:
/usr/bin/pwpolicy -n /Local/Default -getglobalpolicy

maxChars=0 minutesUntilFailedLoginReset=0 maxFailedLoginAttempts=0 minChars=0 requiresNumeric=0 maxMinutesUntilChangePassword=0 requiresAlpha=0 requiresSymbol=0
Now if i try only for "usingHistory=1"

pwpolicy -n /Local/Default -setglobalpolicy "usingHistory=1"

and run the getglobalpolicy then this "usingHistory" is not at all visible.

Now if i run the above commands in OSX 9.4.0 then i can see all the above parameters.

Can you please let me know what is wrong with the above statements.


All times are GMT -4. The time now is 03:18 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.