New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

gfortran and g77 on lion


Post Reply New Thread Subscribe

 
Thread Tools
smriti

 
Member Since: Apr 18, 2012
Posts: 2
smriti is on a distinguished road

smriti is offline
Hi

I got xcode 4.3.2 and put it in applications and am running OS X 10.7.3. I installed g77 and gfortran from sourceforge.net. But when I am compiling a simple test program I get the following error with gfortran.

gfortran: error trying to exec 'as': execvp: No such file or directory

I searched, but there is no as on my system in /usr/local/bin. I am new to Mac so don't know much about the functioning of xcode. Please suggest what to do.

Thanks, Smriti
QUOTE Thanks
xstep

 
xstep's Avatar
 
Member Since: Jun 25, 2005
Location: On the road
Posts: 3,231
xstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to all
Mac Specs: 2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid

xstep is offline
I don't know the problem, but did you install the extra tools. Xcode now installs in the Applications folder and there is an extra, I think command line, toolset to install. Check out the downloads section where you found Xcode 4.3 for that.

Search for the word command in the New Features in Xcode 4.3 document.

CameraTime - Time lapse photography for novice and advanced users.

When asking questions, post the version of your software. You'll receive better answers.

Please post your results to the thread as it is good feedback.
QUOTE Thanks
smriti

 
Member Since: Apr 18, 2012
Posts: 2
smriti is on a distinguished road

smriti is offline
Thanks xstep! That was indeed the problem.. gfortran works fine now.
QUOTE Thanks

Post Reply New Thread Subscribe


« -bash g++:command not found | Static cell will not appear in build as expected? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Looking for g77 compiler for iBook G4 gomex OS X - Operating System 2 11-17-2006 12:10 PM

All times are GMT -4. The time now is 04:26 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?