Results 1 to 3 of 3
  1. #1


    Member Since
    Mar 19, 2012
    Posts
    4
    Undefined symbols for architecture x86_64: error on Xcode
    Hi, I am using Xcode 4 and trying to set up FLTK 1.3.0 to run Bjarne Stroustrup's Chapter 12 FLTK Demo at the end of the chapter. I keep getting the following error when compiling, and have no idea where to go. I have an idea it might have to do with the linker flags, but I don't know what flag to add and where...

    Here's the error:


    Undefined symbols for architecture x86_64:
    "Fl_JPEG_Image::Fl_JPEG_Image(char const*)", referenced from:
    Graph_lib::Image::Image(Point, String, Graph_lib::Suffix::Encoding) in Graph.o
    "Fl_GIF_Image::Fl_GIF_Image(char const*)", referenced from:
    Graph_lib::Image::Image(Point, String, Graph_lib::Suffix::Encoding) in Graph.o
    ld: symbol(s) not found for architecture x86_64
    clang: error: linker command failed with exit code 1 (use -v to see invocation)

  2. #2

    Mark FX's Avatar
    Member Since
    Aug 13, 2011
    Location
    West Sussex, UK
    Posts
    187
    Linker errors are usually associated with not being able to connect to the correct library, so check you
    have included or imported the necessary framework or library.

    sorry I can't be more help.

    Regards Mark

  3. #3


    Member Since
    Mar 19, 2012
    Posts
    4
    Thanks for the reply. I think the error may be due to using code originally written for FLTK version 1.1, whereas I am trying to run that code with FLTK 1.3...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Undefined error: 0 and a flashing questionmark when installing yosemite
    By Numsis123 in forum OS X - Operating System
    Replies: 2
    Last Post: 02-08-2015, 12:36 PM
  2. Xml parsing error: Undefined entity
    By gabor in forum OS X - Operating System
    Replies: 2
    Last Post: 08-05-2013, 09:09 PM
  3. Undefined symbols _main
    By polyfrag in forum OS X - Development and Darwin
    Replies: 1
    Last Post: 07-28-2013, 02:52 AM
  4. -macosx_version_min,10.5 & Undefined symbols __Unwind_Resume
    By colinhercus in forum OS X - Development and Darwin
    Replies: 0
    Last Post: 01-27-2010, 11:10 PM
  5. /usr/bin/ld: Undefined symbols
    By kipepeo in forum OS X - Development and Darwin
    Replies: 1
    Last Post: 05-24-2007, 07:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •