Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Development and Darwin (http://www.mac-forums.com/forums/os-x-development-darwin/)
-   -   'make' command on Mac OS 10.6 (http://www.mac-forums.com/forums/os-x-development-darwin/252264-make-command-mac-os-10-6-a.html)

SeaRox 10-03-2011 12:51 PM

'make' command on Mac OS 10.6
 
I'd say I'm relatively new to Mac and definitely new to programming on a Mac. I'm trying to compile a program to run on my Mac. I looked online and through the forums as much as I could. All the posts I found said that to get the 'make' command you have to install the XCode tools. I have already downloaded the tools from Apple and installed them using the 'XcodeTools.mpkg'. I've rebooted the computer and still I get the error:
make: command not found
I've tried using sudo but I still get the same error.

Is there a way to check and see if they were installed properly?

This is probably a real simple solution but being new I'm missing it.

Any ideas?

vansmith 10-03-2011 01:14 PM

You'll know whether or not Xcode was installed if there is a folder at / called "Developer" (in other words, the folder /Developer should exist).

cradom 10-03-2011 01:18 PM

What he said....also if you do have a Developer folder, What is the output of "echo $PATH" in Terminal without the quotes.

SeaRox 10-03-2011 01:30 PM

@vansmith
Yes there is a "Developer" folder.

@cradom
echo $PATH gives me:
/Library/Frameworks/Python.framework/Versions/2.6/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin

vansmith 10-03-2011 01:38 PM

If you execute the following, do you get anything?
Code:

which make
/usr/bin/make should be printed back.

SeaRox 10-03-2011 01:43 PM

@vansmith
I don't get anything. Just another command prompt.

vansmith 10-03-2011 01:58 PM

Do you have /usr/bin/gnumake? If so, it would seem that the symlink wasn't created which can made by executing the following:
Code:

sudo ln -s /usr/bin/gnumake /usr/bin/make
If you don't have gnumake, the appropriate tools haven't been properly installed. If that's the case, reinstall Xcode.

SeaRox 10-03-2011 02:12 PM

@vansmith
No ... No gnumake. Trying to reinstall XCode ...

SeaRox 10-03-2011 02:35 PM

When trying to reinstall XCode I get a pop up that says "In order to continue installation, please close the following application:"
"iTunes"

The problem is the installer is the only thing running, unless there are some background processes running that I don't know how to see or kill.

cradom 10-03-2011 02:38 PM

Open Activity Monitor and see if Itunes Helper is running. If so, select it and click the Quit Process button.

SeaRox 10-03-2011 02:42 PM

Got it ... "iTunes Helper" was running.

SeaRox 10-03-2011 02:42 PM

@cradom
That was it! Installation resuming.

SeaRox 10-03-2011 02:47 PM

Got it! I now have a 'make' command!

Thanks @vansmith and @cradom!

teo1705 03-01-2012 04:00 PM

For all those that re-installing XCode does not work for, as it didn't for me, you may need more information...

In order to properly work with XCode you need to be registered as an apple developer.
https://developer.apple.com/membercenter

Then, even if you do not get the make command to work you may need to download and install Command Line Tools for Xcode, https://developer.apple.com/downloads

After doing this I was able to get the make command to be recognized.

vansmith 03-01-2012 05:08 PM

You don't have to be a registered developer to work with Xcode. You only need to be registered if you want to submit your app to the App Store.


All times are GMT -4. The time now is 06:34 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.