I have been using gfortran from binary distributions to compile small scientific programs for some time now. Not long ago I decided to try and compile gfortran myself in order to get a better understanding of the gcc compilers and to get more "streamlined" gcc setup. Before I had several fortran compilers that was configured for different things and but what I want is one compiler configured for all my needs, so I figured that this could be done by compiling it myself.

In order to be able to be able to remove the compiler and more importantly install it easily again I use fink to compile the code and install it as .deb packages.
Now this worked out relatively well but I have one problem that I cant figure out:

When I compile my fortran77 code with the -g option in order to debug it it seems like some information about libgfortran in the build directory is added, this causes errors in the gnu debugger as the build directory is long gone.

when I run the program in GDB I get 200 lines like this:

warning: `/sw64/src/fink.build/gcc-gfortran-nicholas-4.5.1-0/gcc-4.5.1/x86_64-apple-darwin10.4.0/libgfortran/.libs/transpose_generic.o': can't open to read symbols: No such file or directory.
where "transpose_generic.o" can be exchanged with any of the ~200 libs, and where : /sw64/src/fink.build/gcc-gfortran-nicholas-4.5.1-0/gcc-4.5.1 was the dir gcc was build in.

I can't figure out if this affects the GDB or not.
Furthermore, I have encountered this problem before with all of the binary distributions of gfortran I have used before.

I guess my questions goes as following: How come gfortran points to some files that were present in the build dir but never installed, and how can this debugging information be removed?

My gcc was configured with the following options:
./configure --enable-languages=fortran --prefix=/sw64

I hope I can get some help in order to understand this problem.