New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

Problems with running c-files


Post Reply New Thread Subscribe

 
Thread Tools
crissy

 
Member Since: Mar 14, 2010
Posts: 1
crissy is on a distinguished road

crissy is offline
I have big problems to run my c -code files on OS X 10.5.
If I try to run my files with gcc -o file file.c and then tries to run it with ./file I get a lot of compilationserrors, it even includes errors that are comment-lines?! very strange! I never could run any c-file, so I need help now please!
I have gcc installed.
X-code does not work, if I try to open a code-file, it just output error message, that It cant run at all.

I also want to know how I run a c.ch file?

Thanks!
QUOTE Thanks
vansmith

 
vansmith's Avatar
 
Member Since: Oct 19, 2008
Location: Toronto
Posts: 18,237
vansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond repute
Mac Specs: 2012 13" MBP (2.5 i5, 8GB)

vansmith is offline
Sounds like you've got errors in your code. Could you post some here? If I can't help, there are a few programmers who lurk around the forums.

Important Links: Community Guidelines : Use the reputation system if you've been helped.
M-F Blog :: Write for the blog
Writing a Quality Post
QUOTE Thanks

Post Reply New Thread Subscribe


« Applescript Help req. as script not working under 10.6.2 | Cannot Install Xcode »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Problems with AVCHD Files The_Grudge Movies and Video 11 08-05-2009 02:48 PM
Running Bootcamp - can you share files on the drives kaelell OS X - Operating System 1 06-15-2008 09:55 AM
Running Windows on Mac rickmahmoud Running Windows (or anything else) on your Mac 7 02-17-2008 12:31 AM
Problems with opening files after installing cloaned HD astarms OS X - Operating System 3 01-25-2008 11:01 AM
Problems loading swf files... MrChris Running Windows (or anything else) on your Mac 0 05-01-2006 06:53 AM

All times are GMT -4. The time now is 03:28 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?