New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

color on the terminal


Post Reply New Thread Subscribe

 
Thread Tools
zero17
Guest
 
Posts: n/a

now, on the terminal mac os x, I don't see colors which are distinguish folders, files, or execute file. different in linux, we are see blue for folders, green for execute files, red for tar files, and etc..

does anyone knows how to enable the colors on the terminal on mac os x, because it seems just has plain, without colors.

thank you all...
QUOTE Thanks
cradom

 
cradom's Avatar
 
Member Since: Feb 14, 2004
Location: Nederland, Texas
Posts: 3,470
cradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant future
Mac Specs: 13in macbook - 10.10.1

cradom is offline
Put this in your .bashrc:


export CLICOLOR='true'
export LSCOLORS="gxfxcxdxbxegedabagacad"

if you want to change the colors, man ls for the settings of the LSCOLORS.

Craig Domingue - resident redneck.
“Never argue with an idiot. He will only bring you down to his level and beat you with experience.”, George Carlin
QUOTE Thanks
zero17
Guest
 
Posts: n/a

Quote:
Originally Posted by cradom
Put this in your .bashrc:


export CLICOLOR='true'
export LSCOLORS="gxfxcxdxbxegedabagacad"

if you want to change the colors, man ls for the settings of the LSCOLORS.
it doesn't work, but thanks for the reply. I don't know why it doesn't work.
QUOTE Thanks
cradom

 
cradom's Avatar
 
Member Since: Feb 14, 2004
Location: Nederland, Texas
Posts: 3,470
cradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant future
Mac Specs: 13in macbook - 10.10.1

cradom is offline
What shell are you using? What version of OS X? Those commands were for bash under 10.3.9.

Craig Domingue - resident redneck.
“Never argue with an idiot. He will only bring you down to his level and beat you with experience.”, George Carlin
QUOTE Thanks
witeshark

 
witeshark's Avatar
 
Member Since: Mar 09, 2004
Location: Miami FL
Posts: 2,860
witeshark will become famous soon enough
Mac Specs: G4 1Ghz OS X 10.4.7

witeshark is offline
Open terminal. Under terminal menu, > Window settings > Click arrows where it says shell. Color is just past half way down
QUOTE Thanks
zero17
Guest
 
Posts: n/a

Quote:
Originally Posted by cradom
What shell are you using? What version of OS X? Those commands were for bash under 10.3.9.
I am using mac os x 10.4 tiger.
QUOTE Thanks
zero17
Guest
 
Posts: n/a

Quote:
Originally Posted by witeshark
Open terminal. Under terminal menu, > Window settings > Click arrows where it says shell. Color is just past half way down
is not that what I mean
QUOTE Thanks
cradom

 
cradom's Avatar
 
Member Since: Feb 14, 2004
Location: Nederland, Texas
Posts: 3,470
cradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant future
Mac Specs: 13in macbook - 10.10.1

cradom is offline
Hmm..try setting it to xterm-color.

export TERM='xterm-color'

Craig Domingue - resident redneck.
“Never argue with an idiot. He will only bring you down to his level and beat you with experience.”, George Carlin
QUOTE Thanks
zero17
Guest
 
Posts: n/a

nope.. doesn't work, I've tried so many ways, but still, it doesn't work.. may be I didn't do it the right way. but thanks for your replies cradom..
QUOTE Thanks
cradom

 
cradom's Avatar
 
Member Since: Feb 14, 2004
Location: Nederland, Texas
Posts: 3,470
cradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant future
Mac Specs: 13in macbook - 10.10.1

cradom is offline
Well, I'm out of ideas and since I'm still in Panther I cant test it. Sorry.

Craig Domingue - resident redneck.
“Never argue with an idiot. He will only bring you down to his level and beat you with experience.”, George Carlin
QUOTE Thanks
aarle
Guest
 
Posts: n/a

One of the first answers
Quote:
Originally Posted by zero17
export CLICOLOR='true'
was close.

You indeed have to set the environment CLICOLOR to true, but in the default tcsh you do this differently.

You could change the example environment file (this will enable color for ALL users): /usr/share/tcsh/examples/environment
and add to it this line: setenv CLICOLOR true
QUOTE Thanks
cradom

 
cradom's Avatar
 
Member Since: Feb 14, 2004
Location: Nederland, Texas
Posts: 3,470
cradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant future
Mac Specs: 13in macbook - 10.10.1

cradom is offline
If he did a clean install of Tiger the default should be bash. If indeed he is using tcsh then my example wont work.

Craig Domingue - resident redneck.
“Never argue with an idiot. He will only bring you down to his level and beat you with experience.”, George Carlin
QUOTE Thanks
mikeazorin
Guest
 
Posts: n/a

zero17, I take it that you are using /Applications/Utilities/Terminal and are not seeing different colors of files and folders while using the 'ls' command. This is the way the 'ls' command works in Mac OS X, and as I am aware there is no way to change it to distinguish filetypes with colors.
QUOTE Thanks
zero17
Guest
 
Posts: n/a

Quote:
Originally Posted by mikeazorin
zero17, I take it that you are using /Applications/Utilities/Terminal and are not seeing different colors of files and folders while using the 'ls' command. This is the way the 'ls' command works in Mac OS X, and as I am aware there is no way to change it to distinguish filetypes with colors.
I see, that sucks then.. thanks mikeazorin
QUOTE Thanks
cradom

 
cradom's Avatar
 
Member Since: Feb 14, 2004
Location: Nederland, Texas
Posts: 3,470
cradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant futurecradom has a brilliant future
Mac Specs: 13in macbook - 10.10.1

cradom is offline
Quote:
Originally Posted by mikeazorin
zero17, I take it that you are using /Applications/Utilities/Terminal and are not seeing different colors of files and folders while using the 'ls' command. This is the way the 'ls' command works in Mac OS X, and as I am aware there is no way to change it to distinguish filetypes with colors.
Not true. Man ls and look where it says Environment.
BTW: I got Tiger now and it works fine, although dark blue on black is hard to read. I need to change that
Are you using bash or tcsh?
Also, in preferences for Terminal, do you have Disable ANSI colors checked?
Uncheck it.

Craig Domingue - resident redneck.
“Never argue with an idiot. He will only bring you down to his level and beat you with experience.”, George Carlin
QUOTE Thanks

Post Reply New Thread Subscribe


« Eventual game design | Help! Building an app from a simple Quartz composition »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
VIM on the terminal zero17 OS X - Development and Darwin 10 06-02-2005 12:04 AM
Terminal Help rs2sensen OS X - Apps and Games 1 04-25-2005 11:52 PM
My Terminal is messed up. edokid Switcher Hangout 8 11-16-2004 03:42 AM
Terminal nøøbizm 3 for the price of 1 Bo Eddy OS X - Development and Darwin 5 05-04-2004 01:40 PM
looking for a terminal emulator and command shell in Mac OSX CandiMarie OS X - Operating System 9 03-05-2004 04:53 PM

All times are GMT -4. The time now is 07:21 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?