New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

help with installing ports thru Darwinports


Post Reply New Thread Subscribe

 
Thread Tools
chefkww
Guest
 
Posts: n/a

Help this newcomer. I am trying to install the port py-gnome thru darwinports everthing was going fine until it got to port libzvt.
This error message was given.

---> Building libzvt with target all
Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync. opendarwin.org_dpupdate_dports_gnome_libzvt/work/libzvt-2.0.1" && make all" returned error 2
Command output: make all-recursive
Making all in libzvt
/bin/sh ../libtool --mode=link gcc -g -O2 -o zterm zterm.o libzvt-2.0.la -L/opt/local/lib -lglib-2.0 -lintl -liconv -lgmodule-2.0 -lgtk-x11-2.0 -lart_lgpl_2
gcc -g -O2 -o .libs/zterm zterm.o -L./.libs -lzvt-2.0 -L/opt/local/lib -lgmodule-2.0 -lglib-2.0 -lintl -liconv -lc -lgtk-x11-2.0 -lart_lgpl_2 -lm
ld: warning prebinding disabled because dependent library: /opt/local/lib/libzvt-2.0.0.dylib is not prebound
ld: zterm.o illegal reference to symbol: _g_signal_connect_data defined in indirectly referenced dynamic library /opt/local/lib/libgobject-2.0.0.dylib
ld: zterm.o illegal reference to symbol: _gdk_window_get_pointer defined in indirectly referenced dynamic library /opt/local/lib/libgdk-x11-2.0.0.dylib
ld: warning multiple definitions of symbol _locale_charset
/opt/local/lib/libiconv.dylib(localcharset.o) definition of _locale_charset
/opt/local/lib/libintl.dylib(localcharset.o) definition of _locale_charset
ld: warning suggest use of -bind_at_load, as lazy binding may result in errors or different symbols being used
symbol _locale_charset used from dynamic library /opt/local/lib/libiconv.dylib(localcharset.o) not from earlier dynamic library /opt/local/lib/libintl.3.dylib(localcharset.o)
make[2]: *** [zterm] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2

Error: The following dependencies failed to build: libzvt nautilus eel librsvg metacity gnome-applets libexif py-gtk2

I have looked everywhere online for similar situations in forums, but can't find really anything to help. Can anyone help?
I have a IMac G5 1.8 / 512 RAM

Thank you.
QUOTE Thanks
chefkww
Guest
 
Posts: n/a

Never mind about this figured it out. May have other questions thourgh,
QUOTE Thanks
rman

 
rman's Avatar
 
Member Since: Dec 24, 2002
Location: Los Angeles, California
Posts: 12,591
rman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud of
Mac Specs: 2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi

rman is offline
You might want to give the solution to your problem. So it can help some one else, who may have the same problem.

Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!
QUOTE Thanks

Post Reply New Thread Subscribe


« Unix Reference Guide | Unix Newb with a question »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
sudo: ports: command not found inflexion OS X - Development and Darwin 16 06-11-2012 01:16 PM
Errors Installing OS X on 333mhz iMac swn5363 Apple Desktops 14 12-23-2004 03:48 PM
Installing Mac Os YYZ Running Windows (or anything else) on your Mac 2 10-07-2004 06:38 PM
Package Management (or, Installing Software) mrchaotica Switcher Hangout 1 02-14-2004 02:08 PM
Help with installing OS X meredith OS X - Operating System 4 09-12-2003 11:44 AM

All times are GMT -4. The time now is 12:10 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?