I was running Python-2.5 and Python-3.0(alongside) without any problem till last night.

I wanted to to some gui programming using tkinter SO I donwloaded and installed. I also installed tcltkaqua. That is where the problem started. After the installation, I found whenever my python IDE starts, I am getting the following error messge,

"error reading package index file /Library/Tcl/tdbc1.0b1/pkgIndex.tcl: expected version number but got "1.0b1""

I think this is the problem of latest Tcl rather than the default, which is 8.4.

Could anyone help me how to resolve this issue?

Thanks in advance.