I'm trying to install sqlite with darwinports. I'm getting the next error:
---> Activating ncursesw @5.7_0
Error: Target org.macports.activate returned: Image error: /opt/local/bin/captoinfo already exists and does not belong to a registered port. Unable to activate port ncursesw.
Error: The following dependencies failed to build: readline ncurses ncursesw
Error: Status 1 encountered during processing.

so i tried to upgrade ncurses or ncursesw which doesn't work.
i checked the installed version
sudo port installed ncurses
The following ports are currently installed:
ncurses @5.5_1+darwin_8

and the variants
sudo port variants ncurses
ncurses has the variants:
universal: Build for multiple architectures
freebsd: Platform variant, do not select manually

I tried uninstalling ncurses but that gives

sudo port uninstall ncurses @5.5_1+darwin_8
---> Unable to uninstall ncurses 5.5_1+darwin_8, the following ports depend on it:
---> texinfo
---> readline

does anyone have a clue how i can solve this?

thanks in advance,