Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Development and Darwin (http://www.mac-forums.com/forums/os-x-development-darwin/)
-   -   Trouble with Objective-c class (http://www.mac-forums.com/forums/os-x-development-darwin/144728-trouble-objective-c-class.html)

blevblev 03-11-2009 02:36 AM

Trouble with Objective-c class
 
I'm an experienced programmer, but a newbie with Objective-C. I am using a sample I found on the internet as a model. All I tried to do, was add a new class to the project - that is, I'm not trying to use it yet, I'm just trying to get the program to compile. When I do, I get several error messages: in the .m file, after the initWithName I get "syntax error before NSString" and then after ever line except "name = nameValue" I get "type defaults to an int" and "addressValue undeclared here" and "data definition has no type or storage class." The strange thing is if I drop the last parameter (zip) it compiles ok. I've tried adding another parameter, but then it doesn't compile again. I also tried changing names around in case I was using reserved words or something (although the compiler should pick that up...)

Like I say, I'm just starting out. HELP! All I'm trying to do is make a class that uses "initialize with arguments" just to try it out.

By the way this editor insists on replacing a colon followed by a left parens with a smiley face. I can't figure out how to tell it not to.

Here's the code: here's Door.h

#import <Foundation/Foundation.h>

@interface Door : NSObject {
****NSString *name;
****NSString *dooraddress;
****NSString *city;
****NSString *state;
****NSString *zip;
}

@property (nonatomic, retain) NSString *name;
@property (nonatomic, retain) NSString *dooraddress;
@property (nonatomic, retain) NSString *city;
@property (nonatomic, retain) NSString *state;
@property (nonatomic, retain) NSString *zip;

-(id)initWithName:(NSString *)nameValue
*******andAddress:(NSString *)addressValue
**********andCity:(NSString *)cityValue
******** andState:(NSString *)stateValue
***********andZip:(NSString *)zipValue;

@end

and here's door.m

#import "Door.h"

@implementation Door
*
@synthesize name;
@synthesize dooraddress;
@synthesize city;
@synthesize state;
@synthesize zip;

-(id)initWithName:(NSString *)nameValue
*******andAddress:(NSString *)addressValue
**********andCity:(NSString *)cityValue
******** andState:(NSString *)stateValue
***********andZip:(NSSTring *)zipValue {
********
****name = nameValue;
****dooraddress = addressValue;
****city = cityValue;
****state = stateValue;
****zip = zipValue;

****return self;
****
}

@end

mystic_fm 03-11-2009 08:22 AM

For your zipValue parameter you have typed in NSSTring rather than NSString. That typo might be your problem.

As far as showing code in a forum post, look into surrounding your code blocks with the CODE tag (surrounded by square brackets, and also available via the '#' button in the advanced post editor's toolbar), which will give you results like this:

Code:

- (id) initWithName:(NSString *)nameValue
        andAddress:(NSString *)addressValue
            andCity:(NSString *)cityValue
          andState:(NSString *)stateValue
            andZip:(NSString *)zipValue;


blevblev 03-11-2009 04:44 PM

That was it. I found out last night by re-typing part of the files, and the error went away. Thanks for the tip about posting code too....


All times are GMT -4. The time now is 08:51 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.