New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

Xcode won't start


Post Reply New Thread Subscribe

 
Thread Tools
computergeek

 
Member Since: Mar 24, 2008
Posts: 40
computergeek is on a distinguished road
Mac Specs: 1.25 GHz PowerPC G4 eMac

computergeek is offline
Hi, I am having trouble with Xcode. I just won't start! I tried to reinstall Xcode and that didn't work either. I have recently upgraded my eMac to Mac OSX.5.5 to OSX.5.6. I am wondering if that messed it up.
QUOTE Thanks
xstep

 
xstep's Avatar
 
Member Since: Jun 25, 2005
Location: On the road
Posts: 3,231
xstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to all
Mac Specs: 2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid

xstep is offline
I don't know but do the usual. Fix permissions, check the log via the Console.app in the Utilities folder. Your XCode should be in /Developer/Applications/ folder.

CameraTime - Time lapse photography for novice and advanced users.

When asking questions, post the version of your software. You'll receive better answers.

Please post your results to the thread as it is good feedback.
QUOTE Thanks
vansmith

 
vansmith's Avatar
 
Member Since: Oct 19, 2008
Location: Toronto
Posts: 18,044
vansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond repute
Mac Specs: 2012 13" MBP (2.5 i5, 8GB)

vansmith is offline
What do you mean it won't open? Error messages? Warnings?

Important Links: Community Guidelines : Use the reputation system if you've been helped.
M-F Blog :: Write for the blog
Writing a Quality Post
QUOTE Thanks
computergeek

 
Member Since: Mar 24, 2008
Posts: 40
computergeek is on a distinguished road
Mac Specs: 1.25 GHz PowerPC G4 eMac

computergeek is offline
I ran Repair Disk Permissions and found the crash log. (in the uploads.)
Attached Files
File Type: txt xcode crash log.txt (106.9 KB, 5 views)
QUOTE Thanks
xstep

 
xstep's Avatar
 
Member Since: Jun 25, 2005
Location: On the road
Posts: 3,231
xstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to all
Mac Specs: 2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid

xstep is offline
I don't know. I'd do a Google search for the two lines that follow "Application Specific Information:". It would appear that you are trying to start up XCode in debug mode. Also run the console, but I think those are the errors you'll see.

CameraTime - Time lapse photography for novice and advanced users.

When asking questions, post the version of your software. You'll receive better answers.

Please post your results to the thread as it is good feedback.
QUOTE Thanks
computergeek

 
Member Since: Mar 24, 2008
Posts: 40
computergeek is on a distinguished road
Mac Specs: 1.25 GHz PowerPC G4 eMac

computergeek is offline
This is the 2 Xcode logs



3/9/09 8:06:54 AM [0x0-0x18d18d] .com.apple.Xcode[5489] objc[5489]: '/System/Library/PrivateFrameworks/DebugSymbols.framework/Versions/A/DebugSymbols' was not compiled with -fobjc-gc or -fobjc-gc-only, but the application requires GC

3/9/09 8:06:54 AM [0x0-0x18d18d] .com.apple.Xcode[5489] objc[5489]: *** GC capability of application and some libraries did not match
QUOTE Thanks
mystic_fm

 
Member Since: Mar 15, 2007
Posts: 161
mystic_fm will become famous soon enough
Mac Specs: 17" MacBook Pro, 2.33GHz C2D, 2GB RAM

mystic_fm is offline
People on the Apple Support forum have been reporting this problem with Xcode 3.0 (NOT the newest Xcode 3.1.2) after installing the Safari 4 beta. They have consistently been able to resolve it by downloading and installing the latest version of Xcode. If you did install the Safari 4 beta and aren't running Xcode 3.1.2 yet, I'd suggest you give their solution a try.

Apple - Support - Discussions - XCode repeatedly crashes on startup ...
QUOTE Thanks
xstep

 
xstep's Avatar
 
Member Since: Jun 25, 2005
Location: On the road
Posts: 3,231
xstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to allxstep is a name known to all
Mac Specs: 2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid

xstep is offline
Google is your friend. I found a discussion on Apple that maybe your answer. These people had installed Safari 4 beta.

P.S. I see mystic_fm beat me to it.

CameraTime - Time lapse photography for novice and advanced users.

When asking questions, post the version of your software. You'll receive better answers.

Please post your results to the thread as it is good feedback.
QUOTE Thanks
computergeek

 
Member Since: Mar 24, 2008
Posts: 40
computergeek is on a distinguished road
Mac Specs: 1.25 GHz PowerPC G4 eMac

computergeek is offline
I am downloading the new Dev Tools.

Geek
QUOTE Thanks

Post Reply New Thread Subscribe


« Sending messages to other object's instances? | Xcode, Subversion, and directory behaviour »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Xcode Help! Kathe OS X - Development and Darwin 1 09-21-2008 02:57 PM
Carbon framework on XCode Rafi Shalom OS X - Development and Darwin 1 04-17-2008 01:14 PM
Mac Pro keeps crashing when using with KVM. where to start my investigation? AlexUK Apple Desktops 6 06-20-2007 05:50 AM
Xcode 1.5 alejandrico OS X - Development and Darwin 0 06-03-2006 05:56 PM
Features I miss from Visual Studio, now using xCode... RChickenMan OS X - Development and Darwin 0 10-18-2005 11:14 AM

All times are GMT -4. The time now is 06:48 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?