Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Development and Darwin (http://www.mac-forums.com/forums/os-x-development-darwin/)
-   -   Xcode won't start (http://www.mac-forums.com/forums/os-x-development-darwin/144396-xcode-wont-start.html)

computergeek 03-08-2009 04:31 PM

Xcode won't start
 
Hi, I am having trouble with Xcode. I just won't start! I tried to reinstall Xcode and that didn't work either. I have recently upgraded my eMac to Mac OSX.5.5 to OSX.5.6. I am wondering if that messed it up.

xstep 03-08-2009 05:02 PM

I don't know but do the usual. Fix permissions, check the log via the Console.app in the Utilities folder. Your XCode should be in /Developer/Applications/ folder.

vansmith 03-08-2009 05:07 PM

What do you mean it won't open? Error messages? Warnings?

computergeek 03-08-2009 09:17 PM

1 Attachment(s)
I ran Repair Disk Permissions and found the crash log. (in the uploads.)

xstep 03-09-2009 12:37 AM

I don't know. I'd do a Google search for the two lines that follow "Application Specific Information:". It would appear that you are trying to start up XCode in debug mode. Also run the console, but I think those are the errors you'll see.

computergeek 03-09-2009 08:10 AM

This is the 2 Xcode logs



3/9/09 8:06:54 AM [0x0-0x18d18d] .com.apple.Xcode[5489] objc[5489]: '/System/Library/PrivateFrameworks/DebugSymbols.framework/Versions/A/DebugSymbols' was not compiled with -fobjc-gc or -fobjc-gc-only, but the application requires GC

3/9/09 8:06:54 AM [0x0-0x18d18d] .com.apple.Xcode[5489] objc[5489]: *** GC capability of application and some libraries did not match

mystic_fm 03-09-2009 11:38 AM

People on the Apple Support forum have been reporting this problem with Xcode 3.0 (NOT the newest Xcode 3.1.2) after installing the Safari 4 beta. They have consistently been able to resolve it by downloading and installing the latest version of Xcode. If you did install the Safari 4 beta and aren't running Xcode 3.1.2 yet, I'd suggest you give their solution a try.

Apple - Support - Discussions - XCode repeatedly crashes on startup ...

xstep 03-09-2009 11:48 AM

Google is your friend. I found a discussion on Apple that maybe your answer. These people had installed Safari 4 beta.

P.S. I see mystic_fm beat me to it. ;)

computergeek 03-09-2009 04:42 PM

I am downloading the new Dev Tools.

Geek


All times are GMT -4. The time now is 11:27 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.