New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Development and Darwin Discussion and questions about development for Mac OS X.

SDL & Xcode problem


Post Reply New Thread Subscribe

 
Thread Tools
jimz

 
Member Since: Apr 26, 2008
Posts: 4
jimz is on a distinguished road

jimz is offline
Hi,

I'm using osx 10.4.11, Xcode 2.2.1

I've downloaded:
SDL-1.2.13.dmg
SDL-devel-1.2.13-extras.dmg

from here:
Simple DirectMedia Layer

I followed the instructions in the readme in SDL-1.2.13.dmg and copied the framework to:

/Library/Frameworks and then also to User/Library/Frameworks when it wasn't working

I then copied the contents of templatesforxcode in to SDL-devel-1.2.13-extras.dmg /Library/Application Support/Apple/Developer Tools/Project Templates/Appllcation and they are showing up when I create a new project in xcode

Whenever I try to compile, using any of the sdl templates, I get this error:

Command /usr/bin/gcc-4.0 failed with exit code 1
/Library/Frameworks/SDL.framework/SDL load command 6 unknown cmd field

So, I'm guessing it's finding the framework, but what does that error mean? And how do I fix it?

Thanks,

Jim.
QUOTE Thanks

Post Reply New Thread Subscribe


« Force an application to open with X11? | Java 3d »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Problem With Keyboard...... mmcltd OS X - Operating System 4 02-02-2010 06:47 PM
Microsoft Messenger Problem millenium_spike OS X - Apps and Games 4 09-16-2008 01:11 AM
Problem Darwin Server + VLC nanaki Web Design and Hosting 0 03-13-2008 07:27 AM
Problem with building up C++ project in Xcode feng.gu OS X - Development and Darwin 2 03-10-2008 02:13 PM
Problem with ethernet board after installing RAM and upgrading from 10.2.8 to 10.3.5 ydonofrio Apple Desktops 4 02-11-2008 07:16 PM

All times are GMT -4. The time now is 12:01 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?