Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   Robust file copy solutions for OS X? (http://www.mac-forums.com/forums/os-x-apps-games/93572-robust-file-copy-solutions-os-x.html)

cwa107 01-21-2008 09:50 PM

Robust file copy solutions for OS X?
 
I'm trying to do what seems like a simple enough task, but I'll be dipped if I can figure out how to make it work. I have two iTunes libraries on two separate machines. My iPod's library is on my Mac and my wife's iPod library is on her Windows laptop. I'd like to copy both libraries into a single folder on my NAS (D-Link DNS-323), which runs some form of Linux.

On the Windows machine, copying the iTunes library was no sweat at all, I just fired up Robocopy from the resource kit and dumped it to the NAS directory. On my Mac, it's been a little more of a challenge. From the errors I've seen, it has something to do with the fact that HFS allows for special characters in filenames that whatever filesystem my NAS box uses does not. And each time I start a copy and the Finder trips up, it aborts the entire copy without giving me the option to just skip the single offending file.

So, I've started to look for tools like Robocopy for OS X. So far I've found RsyncX, which looks exceedingly complicated. I've also tried PsyncX, which errors out before it even starts - my guess is that it's just not Leopard compatible. Then I found ChronoSync - looks great and should do the trick, the only problem is that the demo is limited to a few hundred files and I've got something like 2000+. Normally, I would happily pay the $30, as it seems like a worthwhile product, but at the moment, I really only foresee using it this one time.

There's got to be an easy way to copy this directory that I'm overlooking. Any advice or ideas would be greatly appreciated.

cwa107 01-22-2008 01:55 PM

A couple of updates for anyone that may be interested:

1. I've tried RsyncX and it's not complicated as I originally implied. It's Rsync (the UNIX command) that is really complicated. I was hopeful that this would work, but after 30 minutes of it analyzing the directories, it failed with a vague error message.

2. I tried initiating a Robocopy from Windows XP running within Parallels - while it was a cool idea, it didn't pan out so well. It claimed to complete the copy with about a dozen errors, but in reality, nothing changed in the destination directory.

Maybe it's time to just give up and buy Chronosync.

louishen 01-22-2008 03:58 PM

can you connect to your mac from the windows pc and copy the files from your mac, but with her windows PC?

cwa107 01-22-2008 04:05 PM

Quote:

Originally Posted by louishen (Post 577757)
can you connect to your mac from the windows pc and copy the files from your mac, but with her windows PC?


I hadn't thought of that, not a bad idea at all - use the Windows machine as an intermediary to copy the files to. Then, copy them back from the Windows machine to the NAS.

I'm at work at the moment, but I think you may be onto something there. I may even be able to copy them to my Parallels/Windows session and then copy them to the NAS from that session.

Thanks and I'll update the thread with my results.

cwa107 01-24-2008 09:49 PM

Louishen - that worked, thanks for the suggestion!


All times are GMT -4. The time now is 07:37 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.