New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

Calling All Safari Users -- Possible Serious Flaw In Safari?


Post Reply New Thread Subscribe

 
Thread Tools
slinki

 
slinki's Avatar
 
Member Since: Oct 14, 2007
Location: Northern Ireland
Posts: 144
slinki is an unknown at this point
Mac Specs: 24" iMac, 2.8GHz Core 2 Extreme, 500+500GB HD, 4GB RAM, OSX 10.5.1

slinki is offline
Hi all,

In my continual effort to use as much of macs own native software as possible, I just tried moving from Firefox to Safari.

Everything was going ok, I even managed to get my bookmarks imported.

Then I tried to save something from a link. I.e. "save link as" in Firefox, or "save target as" in Internet Explorer..I think.

Anyway, Safari seems to have an issue with doing this..in that it doesn't. It says "file doesn't exist" in its little downloads window, after failing to even start the download. The file is def' there as it will play in the browser upon left clicking it.

Has anyone had any experience with this? Or perhaps moved from Firefox to Safari themselves?

Thanks
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,044
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Does this happen with any link, or a specific one? Can you give an example?
QUOTE Thanks
knightlie

 
knightlie's Avatar
 
Member Since: Mar 22, 2007
Location: UK
Posts: 1,463
knightlie is just really niceknightlie is just really niceknightlie is just really niceknightlie is just really nice
Mac Specs: Lenovo Z560 Hackintosh -:- '06 iMac -:- iPod Touch 2ndGen

knightlie is offline
Quote:
Originally Posted by slinki View Post
The file is def' there as it will play in the browser upon left clicking it.
What kind of file is it? This implies is video or audio, the site may be preventing you from downloading it directly. Have you tried with other files?

I don't think there are any "serious flaws" in Safari that prevent it from downloading files.

[URL="http://beadia.net"]Beadia[/URL - Jewelry Business Management Software]
I judge you when you use poor grammar.
QUOTE Thanks
slinki

 
slinki's Avatar
 
Member Since: Oct 14, 2007
Location: Northern Ireland
Posts: 144
slinki is an unknown at this point
Mac Specs: 24" iMac, 2.8GHz Core 2 Extreme, 500+500GB HD, 4GB RAM, OSX 10.5.1

slinki is offline
Quote:
Originally Posted by lifeisabeach View Post
Does this happen with any link, or a specific one? Can you give an example?
Quote:
Originally Posted by knightlie View Post
What kind of file is it? This implies is video or audio, the site may be preventing you from downloading it directly. Have you tried with other files?

I don't think there are any "serious flaws" in Safari that prevent it from downloading files.
To demonstrate what I mean, please click the following link,

http://www.speedyshare.com/558362895.html

Its safe don't worry. What I done was, I saved a random image off google (of a mac computer), then uploaded it to speedyshare, so you all could see my problem.

If you left click the link, the image will show. So we know its def' there, and that its working. However, if i wanted to save that image to my computer, I would right click, and select "download linked file as', or even simply "download linked file".

I do this a million times a day with firefox, with no problems.

its the exact same with video, music, and whatever else you can think of.

Do you all see what I mean now? It wont start the download
QUOTE Thanks
MacHeadCase
Guest
 
Posts: n/a

I got the image to download just fine. It's here on my desktop.


Edited to add:

And I used Safari for this.
QUOTE Thanks
slinki

 
slinki's Avatar
 
Member Since: Oct 14, 2007
Location: Northern Ireland
Posts: 144
slinki is an unknown at this point
Mac Specs: 24" iMac, 2.8GHz Core 2 Extreme, 500+500GB HD, 4GB RAM, OSX 10.5.1

slinki is offline
using the "download linked file as" ??
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,044
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
I was fully expecting to tell you it worked fine, then my eyes bugged out as I get the error "0 bytes of ? -- file doesn't exist".

What version of Safari do you have, and what OS version? I have OS 10.5.1 with Safari 3.0.4. The only Safari add-on I have is Pith Helmet, and it's off at the moment. Well I do have Speed Download also. I have a bare install of OS X on another partition... lemme try on there and see what happens.

EDIT: I booted into my "virgin" install of 10.5.1 on another partition and I still had the problem. MHC is running Tiger, iirc, so since she had no problems, and assuming you are on 10.5.1 like myself, then I feel pretty confident in calling this a bug with Safari and/or OS 10.5.1
QUOTE Thanks
northy124

 
Member Since: Oct 17, 2007
Posts: 288
northy124 can only hope to improve
Mac Specs: 2.16 GHz C2D, 1GB Ram, MacBook White

northy124 is offline
Works fine in both FireFox and Safari for me
QUOTE Thanks
MacHeadCase
Guest
 
Posts: n/a

Quote:
Originally Posted by slinki View Post
using the "download linked file as" ??
Yes that's what I used. And yes I am using Tiger 10.4.11. To make sure this is a system-wide thing, create a new user account and see in that new account if the problem happens there as well.

Although if you and lifeisabeach are experiencing the same problem, something tells me the next Leopard update has something else to patch...
QUOTE Thanks
technologist

 
Member Since: Mar 30, 2004
Location: USA
Posts: 4,744
technologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond repute
Mac Specs: 12" Apple PowerBook G4 (1.5GHz)

technologist is offline
It could be a connection issue with the server or your ISPs.

I had no problems with that file.
QUOTE Thanks
slinki

 
slinki's Avatar
 
Member Since: Oct 14, 2007
Location: Northern Ireland
Posts: 144
slinki is an unknown at this point
Mac Specs: 24" iMac, 2.8GHz Core 2 Extreme, 500+500GB HD, 4GB RAM, OSX 10.5.1

slinki is offline
Quote:
Originally Posted by lifeisabeach View Post
I was fully expecting to tell you it worked fine, then my eyes bugged out as I get the error "0 bytes of ? -- file doesn't exist".

What version of Safari do you have, and what OS version? I have OS 10.5.1 with Safari 3.0.4. The only Safari add-on I have is Pith Helmet, and it's off at the moment. Well I do have Speed Download also. I have a bare install of OS X on another partition... lemme try on there and see what happens.

EDIT: I booted into my "virgin" install of 10.5.1 on another partition and I still had the problem. MHC is running Tiger, iirc, so since she had no problems, and assuming you are on 10.5.1 like myself, then I feel pretty confident in calling this a bug with Safari and/or OS 10.5.1

Well at least it isn't just me! Yes, I am running Leopard (10.5.1) and Safari (3.0.4), so I think it is indeed a Leopard thing.

Quote:
Originally Posted by northy124 View Post
Works fine in both FireFox and Safari for me
What OS version are you using? Tiger? Leopard?

Quote:
Originally Posted by MacHeadCase View Post
Yes that's what I used. And yes I am using Tiger 10.4.11. To make sure this is a system-wide thing, create a new user account and see in that new account if the problem happens there as well.

Although if you and lifeisabeach are experiencing the same problem, something tells me the next Leopard update has something else to patch...
Yeah it seems to be a leopard thing.

Quote:
Originally Posted by technologist View Post
It could be a connection issue with the server or your ISPs.

I had no problems with that file.
It works with Firefox so I think that would rule out what you said
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,913
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.10.1, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
Just confirmed, it works in Tiger 10.4.11 by right clicking and going save but not with 10.5.1 Leopard. Funny since both now use Safari 3. I always just drag the picture to the desktop with the mouse so I would have never noticed.

Funny thing is I can go to many other sites and right click and download a pic or file.
QUOTE Thanks

Post Reply New Thread Subscribe


« Recovering Serial Numbers | spore for mac? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Calling all Photoshop users : Help Required TornSi Images, Graphic Design, and Digital Photography 14 08-28-2007 05:18 AM
Just How Secure Are the 'Reset Safari' & 'Erase Free Space' Facility? scoot OS X - Operating System 3 05-30-2007 06:28 PM
calling all iklear users Virusyn Schweb's Lounge 3 12-24-2006 01:08 PM
Calling for all Mac users please help!!!!!! New2Macs Schweb's Lounge 5 04-02-2006 04:07 AM
Question for Safari users (especially older versions) thendis OS X - Apps and Games 1 06-04-2005 01:58 AM

All times are GMT -4. The time now is 10:25 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?