New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

Keyboard Doesn't work with emulators??


Post Reply New Thread Subscribe

 
Thread Tools
jmo88

 
Member Since: Jan 03, 2008
Posts: 9
jmo88 is on a distinguished road

jmo88 is offline
I have a power Mac G5 running Leopard using the keyboard that was shipped with it. The keyboard doesn't work with any of the emulators I have downloaded such as Nestopia, bsnes. I have searched around and no one else who uses nintendo emulators has this problem, so I assume it is something I am missing outside of the Emulator app. I have spoken with the Emulator's creator and he has no idea except that maybe there is third party software interference.

Any Ideas?
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,001
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Do you have a bluetooth keyboard or USB?
QUOTE Thanks
jmo88

 
Member Since: Jan 03, 2008
Posts: 9
jmo88 is on a distinguished road

jmo88 is offline
Quote:
Originally Posted by lifeisabeach View Post
Do you have a bluetooth keyboard or USB?
I am using a usb keyboard
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,001
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
I just read this blurb about Nestopia.... have you tried this?
Quote:
One of the first things you should do after downloading the emulator and roms is to configure your keyboard. This can be accomplished by going to the “Joysticks” tab in preferences. There is also an option to download emulator enhancer to configure USB joysticks and gamepads to really relive the experience
QUOTE Thanks
jmo88

 
Member Since: Jan 03, 2008
Posts: 9
jmo88 is on a distinguished road

jmo88 is offline
Quote:
Originally Posted by lifeisabeach View Post
I just read this blurb about Nestopia.... have you tried this?
Thanks but I have tried to adjust the configuration. Not a single key does anything to affect the app. The only keys that work while the app is up are Function keys for Spaces and Dashboard.

This is really odd. I have also tried using an old mac keyboard... same thing.
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,001
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
I decided to try downloading Nestopia and a Mario Brothers ROM to see if I could figure this out. At first, I thought my keyboard wasn't being recognized either, then I finally realized I just wasn't hitting the right keys.

Make sure you have the latest version (1.37, link below); go to the config menu and use the defaults button; try to start a game by pressing the TAB key.

If this doesn't work, then we need to see if something else is interfering with the emulator. Create a new user and see if it works under that user. If it does, then something in your user's login items or Library is causing a problem.

If it doesn't work under the new user, then it may be something in the root Library. Boot in Safe Mode by holding down the shift key while rebooting. You'll know yer in Safe Mode by the text under the progress meter. Once in Safe Mode, try it again. If it still doesn't work, then while still in Safe Mode, log into that new user and try again. Be aware that you likely will have no sound while in Safe Mode... that's normal.
QUOTE Thanks
jmo88

 
Member Since: Jan 03, 2008
Posts: 9
jmo88 is on a distinguished road

jmo88 is offline
Quote:
Originally Posted by lifeisabeach View Post
I decided to try downloading Nestopia and a Mario Brothers ROM to see if I could figure this out. At first, I thought my keyboard wasn't being recognized either, then I finally realized I just wasn't hitting the right keys.

Make sure you have the latest version (1.37, link below); go to the config menu and use the defaults button; try to start a game by pressing the TAB key.

If this doesn't work, then we need to see if something else is interfering with the emulator. Create a new user and see if it works under that user. If it does, then something in your user's login items or Library is causing a problem.

If it doesn't work under the new user, then it may be something in the root Library. Boot in Safe Mode by holding down the shift key while rebooting. You'll know yer in Safe Mode by the text under the progress meter. Once in Safe Mode, try it again. If it still doesn't work, then while still in Safe Mode, log into that new user and try again. Be aware that you likely will have no sound while in Safe Mode... that's normal.
Thanks, I would have never figured that out. It works with a new user however it is unable to launch on safe mode (not sure that matters at this point however). SO, any ideas what would cause the interference? I would really not like to have a new user just for using an emulator.

Thanks again though, I appreciate it your fast responses.
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,001
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Great.... so clearly we have a problem with something that is loading for your original user. Next thing to try is going to the System Preferences > Accounts and make a note of all the login items for your user. Then remove them all. Reboot and see if the emulator works. If so, then one of those items was the problem. It's just a matter of re-adding them one at a time to see what the culprit was.

If removing those doesn't do the trick, then something is foul in your Library. We'll tackle that last if need be.
QUOTE Thanks
jmo88

 
Member Since: Jan 03, 2008
Posts: 9
jmo88 is on a distinguished road

jmo88 is offline
Quote:
Originally Posted by lifeisabeach View Post
Great.... so clearly we have a problem with something that is loading for your original user. Next thing to try is going to the System Preferences > Accounts and make a note of all the login items for your user. Then remove them all. Reboot and see if the emulator works. If so, then one of those items was the problem. It's just a matter of re-adding them one at a time to see what the culprit was.

If removing those doesn't do the trick, then something is foul in your Library. We'll tackle that last if need be.
That was it. I had four login items. I removed them and it works. I don't know where those login items went...oops. Oh well though, it works and I don't really need those login items anyway. They were iTunes Helper, Quicken, Adobe CS3 updater, and Microsoft AU.

I have a feeling it was the Quicken. Anyway, thanks. Little things like that can really eat at me.
QUOTE Thanks

Post Reply New Thread Subscribe


« GarageBand for OS 10.3.9 ? | What are the steps to save a Publisher file as a PDF? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Trackpad and keyboard no longer work.. rift0065 Apple Notebooks 5 06-28-2007 09:24 PM
Keyboard, TrackPad don't work with Vista using BootCamp jack963 Running Windows (or anything else) on your Mac 1 06-14-2007 09:16 AM
Is it possible to replace a Danish Keyboard with an American Keyboard?? lresig Apple Notebooks 0 05-07-2007 03:00 PM
Weirdly Locked Key Combos when Using USB Apple Pro Keyboard dorisdanglehoff Apple Notebooks 0 11-09-2006 08:09 PM
Bluetooth Keyboard and Mouse ApplejustWorks Apple Desktops 3 06-21-2004 06:46 AM

All times are GMT -4. The time now is 12:43 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?