I just want to pass on what I just figured out now.

I tried to use Appleworks on leopard and it quit on launch of the app. So I hunted around and realised it doesn't like auto saving and a few other things. So if the app doesn't work for you just do this and it should work like a charm. It did for me.

1. Find the Recent Items folder and delete the aliases inside it.

Find it at:
<YourMacintoshHD/Users/YourName/Documents/AppleWorks User Data/Starting Points/Recent Items>

2. Find the Auto Save folder and delete the documents inside it.

Find it at:
<YourMacintoshHD/Users/YourName/Documents/AppleWorks User Data/AutoSave>

3. Start up Apple works and go to the prefrences.

Disable these preferences:

Choose the AppleWorks > Preferences > General menu.
Set At Startup Show, to Nothing
Select the Files option in the Topic popup menu.
Uncheck the Auto-Save and Recent Items checkboxes.
Click the OK button.

That should be it. Now the app will work just like normal in Leopard.