Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   Chicken of the VNC Help (http://www.mac-forums.com/forums/os-x-apps-games/86638-chicken-vnc-help.html)

verrami 11-29-2007 06:14 PM

Chicken of the VNC Help
 
Hi,

I am a new mac user and installed chicken of the VNC to connect to a linux server (which is configured for tightVNC). I can ping the server and telnet to it without a problem but when I try to connect to it using chicken VNC, I am not getting anything.

I enter the host ip address and click connect on the "Open connections.." menu item and it seems to connect but I am not getting the follow up window that lets me access the server.

I was able to get to the server using a PC but unable to do using this machine.

Any advice on setting this up would be greatly appreciated.

Thanks,

verrami

mathogre 11-29-2007 07:57 PM

It's real easy, but you need to make sure you're doing it right.

With TightVNC, for your connection you enter something like hostname.domain.org:display

mylinuxserver.work.com:0

In CotVNC you enter hostname.domain.org in the Host entry and display in the Display entry.

Host: mylinuxserver.work.com

Display: 0

I use both TightVNC at work and Chicken of the VNC on my Mac at home. Both work just fine. Let me know if this helps. Good luck!

verrami 11-30-2007 09:13 AM

Thanks for the reply.

I give the ip of the server in the host space: 192.168.xxx.xxx and then I give the port its on in the display (1 in this case). When I click connect, it seems to connect but I do not get the follow up window. When I tried to go to full screen I see the entire screen becomes gray.

I really need to get this working.

Thanks,

Vishnu

mathogre 11-30-2007 09:51 AM

I'm at work and am away from my Mac. However, here's something to look at.

How is your firewall set up on your Mac? The services port I use for TightVNC is 5901. If your firewall is fully open for all services, this probably isn't an issue. However, if you're set to allow network connections only on specified ports, then you would probably need to add the relevant port to your firewall.

Here's another set of questions. You say your linux machine is configured for TightVNC. I don't understand. I am currently connected to a linux server via TightVNC, and my setup in my .vnc directory has nothing specific to TightVNC. In there I have my password file, the PID file, and my log file. I started my vnc session over a month ago, and I attach to it with either TightVNC or CotVNC, as a function of what machine I'm using. (The linux machine is running Red Hat Enterprise 4.)

Have you successfully attached to your linux machine with TightVNC? I assume you have, but I'm asking out of completeness. If you have, check the parameters you're using and see that you've set your Mac to use a similar setup.

Is your router blocking the services port from your Mac? Your router may have a built-in firewall that is preventing communication across whatever port your Mac is trying to use. Maybe your PC and Mac are using different services ports for VNC, where the PC is on an open port and the Mac is on a closed one. If so, add the appropriate port to your router.

If none of that helps and you'd like further assistance, you need to provide lots more details about what you're doing and what you've done. Otherwise I can't guess what else to do.

Hope this helps!

verrami 11-30-2007 11:15 AM

Thanks again. I will try and verify all those things you mentioned. Thing is that I am able to telnet to the server and ping it as well. I can work with the server using the terminal.

I actually ran COTVNC via terminal and it seems to connect and I get this message in the terminal window:

2007-11-30 11:12:37.510 Chicken of the VNC[705:10b] Server reports Version RFB 003.130

But I do not get a window giving me access to the server. Does the above message make any sense? Thanks again.

mathogre 11-30-2007 11:42 AM

I don't understand everything in the message you get back from CotVNC, but that's because I've never started it from a terminal. It at least shows that CotVNC is up and running, so that's a good thing.

Have you actually started the vncserver on the linux machine? This requires that you login to the linux machine, run the command "vncserver" (with options as needed), which will return the display port. My guess is you already have done this and know what to do, but I'm asking for completeness.

Have you been able to connect to the linux box using TightVNC from your PC?

verrami 11-30-2007 11:55 AM

I am using a PC in parallel where I have TightVNC running. I am able to easily access the server using TightVNC. When I do full screen I just get a gray screen which might indicate that it could be a display issue too?

mathogre 11-30-2007 04:16 PM

This is good that you're accessing the server with TightVNC. That means a connection to your linux machine is possible.

When you say that you get a gray screen when you do a full screen, is this in TightVNC (TVNC) or CotVNC? If it's in TVNC, when you're not using a full screen, do you have access to your desktop environment? Can you run things? Can you pull up an xterm? Browser? Other application? If you can, this is good! If you have what amounts to a full linux environment through TVNC, this is obviously what you want. If you can't, then you're not really connecting the way you need to connect. Knowing these details helps me to figure out what you're encountering.

What are you running for a linux distro, btw? What's your desktop environment? Gnome? KDE? Alternatively, are you running just a plain window manager such as fvwm or enlightenment?

This is a challenge. CotVNC was actually easy for me to get running on my Mac.

verrami 12-01-2007 08:57 PM

The gray screen comes when I use CotVNC. TightVNC works well.

I tried other VNC clients like JollysFastVNC and VNC viewer and I am able to access the server. Unfortunately, both of them have some functional issues (in ability to right-click on JFVNC and unable to use full key board functionality in VNC viewer). I download VINE server and viewer and it works much better.

I think the problem with cotVNC is that development has stopped and no one is there is to provide support to issues.


All times are GMT -4. The time now is 08:32 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.