Starting yesterday (Sunday), when I open iTunes, as usual, my podcasts want to start updating. However, after about 7 go into the queue, iTunes hangs and starts beachballing. I have to force quit to be able to get out. I notice that when the beachballing starts, the MB fan comes on – coincidence? Or expected? Here is what I have done so far:

1. Repaired permissions
2. Ran MacJanitor
3. Ran OnyX
4. Restarted several times
5. Opened a test user and downloaded a song from iTunes, and also a podcast. This worked fine, however, it did not take very long, and so may just not have been trying long enough to have started beachballing.
6. Removed various .plist preferences (then put the old ones back since that did not change anything)
7. Updated iTunes via the Apple website.

Nothing has helped. I have tried having only iTunes open, so that it is the only thing running, but that did no good either. I don’t have any helper apps going, and have not added or changed anything since the last time I updated iTunes. Although, as I think about it, I MAY have let software update install whatever updates were out there after my last iTunes podcast update. Just can’t be sure of the chronology there.

FWIW – I am using a cable modem and have 2 gig of RAM, otherwise stock MB – 2.0 Ghz processor, etc. I have plenty of hard drive space, as I have my music and photos on an external.

Hoping somebody out there has a solution. I need my daily fix of podcasts!