Hi all. I have a question about an issue I'm having, and I've already checked with Google searches and in these forums but haven't found a complete answer yet (but I have found a workaround).

I bank with Bank of America, and since pulling out my old iMac I haven't been able to login to my online banking, with one exception I'll tell in a bit. When I type in my login info, but before I get to where I enter my password (BoA has these on two separate pages), I get the following error:

Bad Request
Your browser sent a request that this server could not understand.

I tried Safari, Camino, Shiira, Opera, IE, Netscape, and Firefox. All do the same thing.

Now, I was able to log in and pay bills last night, but only thanks to a trick I picked up while reading some linux forums. If I run my browser as root (i.e. sudo the browser), then it works just fine. But this doesn't make sense, since my user account in MacOS is an admin account. Why would I need superuser priviledges to get to my online banking anyway? Also, on that forum, some stated that other user accounts worked as well as root (sudo); it was just their particular account that didn't work. I only have one account on my machine, so I was unable to test this theory out.

For completeness, I found a website that stated this as a reason for the error:

You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

(Reference: http://support.smallbusiness.miva.co...barticleid=170)

But the https:// should be added by the link or login button, since it works on other browers. I don't think I should have to manually enter it.

I'm just not sure what to do. I really would rather not have to use sudo everytime I want to do online banking. It is not the site (or shouldn't be) since I can reach it fine as sudo or from work and even from my linux box at home.

Help? Comments? Suggestions? Any and all are greatly appreciated. As my Mac specs states, I'm using MacOS 10.3.9.