Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   upgrade applescript editor (http://www.mac-forums.com/forums/os-x-apps-games/310384-upgrade-applescript-editor.html)

tcpms 04-10-2014 04:07 PM

upgrade applescript editor
 
I have a script in one of my applications that works fine using version 2.4. The script fails for one of my clients. They have applescript editor version 2.3.

I can't figure out what to tell them to do to upgrade their applescript editor to 2.4.

Any suggestions?

vansmith 04-10-2014 06:56 PM

I'm pretty sure the AS editor is part of OS X and is not installable as a separate component. In other words, to update the AS editor, you have to update OS X.

Slydude 04-10-2014 07:00 PM

not a scripting genius but the version of AppleScript Editor might not be the issue. It's possible that the script uses a function that is not supported for other reasons. Let me explain this way. Let's say you have an application installed. Your client has an older version of the same program. It's possible that your newer version has some AppleScript functions built in that the older version does not have.

There are a few questions that come to mind:

1. When you run the script is it running from inside Script Editor or has it been saved as an application? If you haven't done so I would try that.

2. Are you getting any kind of error message when the script runs?

TattooedMac 04-10-2014 08:10 PM

Yes I agree with Sly above and Van.
There are other problems running here as a script is backwards compatible, but the scriptable properties of the built-in apps, and even the OS can certainly change between versions... You need to find out what .v App it is your trying to run the script on your friend has, what OS and such.
Maybe even drop the script in here using the tags and let us see if its a .v problem or something else.

cradom 04-11-2014 04:28 AM

Also if going between versions of operating systems you need to be using source not compiled scripts.
In other words, give the client the source of the script and let them compile to application so it's compatible with their OS.


All times are GMT -4. The time now is 07:16 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.