Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   All of the apps I install don't respond! help!! (http://www.mac-forums.com/forums/os-x-apps-games/307325-all-apps-i-install-dont-respond-help.html)

nickismusic 01-02-2014 08:38 PM

All of the apps I install don't respond! help!!
 
I have multiple programs that I have tried getting to work but have no luck running.
I got my iMac for the core reason of recording music, for preproduction for when we go to the studio. I used to have a PC and decided to make the switch, best decision ever.
Anyways, multiple programs, (I.E. Guitar Pro 6, Logic Pro, Ableton Live, and Guitar Rig), I will install perfectly fine then when I try to run them, they will sit on the load up screen with the beach ball and say "program not responding" and I'll have to force quit. I've tried everything I know that I could do to fix them. I've tried reinstalling them, installing on a different account, etc. What other options would I have to diagnosing the problem? I don't really know how to use most of the utilities in the "other" folder on my launchpad.
I'm pretty new to Macs so any information is gonna be helpful!
Thanks so much.
Nick

pigoo3 01-02-2014 08:44 PM

How old are all of these applications...and what OS version is the iMac running?

If the applications are too old...and the OS version is somewhat newer...it's possible there are some compatibility problems.

ferrarr 01-02-2014 08:46 PM

Hi, can you tell us what iMac you have?

nickismusic 01-02-2014 08:49 PM

Right now I have OS X Version 10.8.3
2.9 GHz i5
Most of the apps are up to date

pigoo3 01-02-2014 08:56 PM

Quote:

Originally Posted by nickismusic (Post 1559970)
Most of the apps are up to date

Thanks for the OS info...but the app info isn't enough. "Up To Date" can mean many things. The question is...how old are these apps. What versions are they...and what year were they released?

For example...someone can be running Adobe Creative Suite 3 app's (CS3)...and all of these apps can be "Up To Date". But since CS3 is from 2007...those apps are still old. CS6 being the most current.

So it's important to know how old your apps are.

nickismusic 01-02-2014 09:19 PM

I know the Guitar Pro 6 is from a couple years back(2010/11 I believe)
Guitar Rig is 5.1.0, from 2012
Logic Pro X is 10.0.4 from 2013(Aug/Oct)

nickismusic 01-02-2014 09:20 PM

Abelton Live is from March 2013 and its V 9.0.1

pigoo3 01-02-2014 10:19 PM

Ok...thanks for all that info!:) With the "newness" of the apps...and the iMac is running Mac OS 10.8.3...I'm not really seeing a reason why these apps shouldn't work.

So my next 2 questions:

- Are these apps Macintosh versions or Windows versions? I know that Logic Pro X is a Mac Only app...but I wasn't 100% sure of the others.

- Did you purchase all of these apps (with original install media and/or serial numbers)...or were these apps obtained via other means (which could make them more difficult to install successfully)?

nickismusic 01-03-2014 01:02 AM

Yeah I purchased a few of them, the others were given to me by a friend. I know for a fact they have worked on other Macs though.
yeah all of them are for Mac, and they all installed successfully, but will not go past the startup logo screen for each app.

Also, when I first got the iMac, i tried using Garageband and the same thing happened. So it isn't just applications I have put on here.

McBie 01-03-2014 06:25 AM

If you launch console.app from Applications/utilities .... are there any error messages in the logfile.
That might give you an indication/error code and may point you further in the investigation as to why these apps. have a problem.

Cheers ... McBie

nickismusic 01-03-2014 09:08 AM

I got these:
1/3/14 9:00:41.589 AM GuitarPro[4448]: OS version : 10.8

1/3/14 9:00:41.589 AM GuitarPro[4448]: Check done, use Cocoa

1/3/14 9:02:45.266 AM spindump[4456]: Saved spin report for GuitarPro version ??? (???) to /Library/Logs/DiagnosticReports/GuitarPro_2014-01-03-090245_Nicks-iMac.spin

1/3/14 9:03:12.853 AM spindump[4464]: Saved spin report for GuitarPro version ??? (???) to /Library/Logs/DiagnosticReports/GuitarPro_2014-01-03-090312_Nicks-iMac.spin

then i opened the last spin report and it said:

Date/Time: 2014-01-03 09:03:01 -0500
OS Version: 10.8.3 (Build 12D78)
Architecture: x86_64
Report Version: 11

Command: Guitar Pro
Path: /Applications/GuitarPro.app/Contents/MacOS/GuitarPro
Version: ??? (???)
Parent: launchd [306]

PID: 4448
Event: timeout
Duration: 10.02s
Steps: 101 (100ms sampling interval)

Hardware model: iMac13,1
Active cpus: 4
Free pages: 744293 pages (-1126)
Pageins: 2 pages
Pageouts: 0 pages


Process: GuitarPro [4448]
Path: /Applications/GuitarPro.app/Contents/MacOS/GuitarPro
Architecture: i386
Parent: launchd [306]
UID: 501
Task size: 8869 pages

McBie 01-03-2014 10:01 AM

The fact that spindump is running indicates an application/process that is not responsive anymore( hangs)
Are you sure Guitar Pro is the latest version for your OS ?
Are you running other apps that may be competing for the same ( audio ) device ?
Not sure this has anything to do with it, but it is worthwhile reading ( threads are old, but you never know )

https://discussions.apple.com/message/9662101#9662101
Improve Mac OS X performance under load by disabling spindump. | James Reuben Knowles

https://discussions.apple.com/message/7087216#7087216
https://discussions.apple.com/thread...rt=15&tstart=0

I have no experience with Guitar Pro, so the links above my not be the solution, but it may be a start.

Cheers ... McBie


All times are GMT -4. The time now is 08:44 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.