Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   Safari 7 won't remember my Mac-Forums username and password (http://www.mac-forums.com/forums/os-x-apps-games/306496-safari-7-wont-remember-my-mac-forums-username-password.html)

matrixbud 12-07-2013 12:11 PM

Safari 7 won't remember my Mac-Forums username and password
 
I have checked the box in Autofill preferences for User names and passwords. I have even installed the autocomplete extension that supposedly fixed this problem for Safari 6 and earlier. I can use 1Password to enter this information for me but I want Safari to just remember it. Does anyone have a suggestion?

Also, I have examined both Safari Passwords (in Safari preferences) and Keychain Access, and this web site is not listed in either place.

osxx 12-07-2013 12:34 PM

When you logged in did you check the box remember me on this website?
Also if you reset Safari you will have to re-enter passwords.

matrixbud 12-07-2013 03:44 PM

Thanks for the quick response. Yes, I checked the box to remember me.

I havent, and hope not to have to, reset Safari.

osxx 12-07-2013 08:51 PM

Make sure you do not have Private Browsing checked in Safari Preferences.

Lifeisabeach 12-08-2013 09:37 AM

If "Private Browsing" isn't the problem, then can you provide a link to that "autocomplete" extension? And any other extensions/add-ons you may be using, especially related to cookies? I have a cookie manager in which I have this and several other sites whitelisted so my login stays saved.

alicepattinson 12-08-2013 10:34 AM

You can also use LastPass to remember your passwords.

matrixbud 12-08-2013 02:31 PM

Thanks, all, for the replies. Here are responses to your items.

1. I do not have Private Browsing checked.
2. I just now installed LastPass but that doesn't work for this site. LastPass requires email addresses as logins, and this forum doesn’t use email addresses. I tried to use it for the password only, but it still required an email address for login.
3. I access the forums web pages at http://www.mac-forums.com/forums/log...d430f34e731fe4, enter my login info, log in and then out, and the login name and password remain blank. I also tried logging in from the home page, Mac Forum & Discussions on Apple Products and Services.
4. I have quite a few extensions so I turned off extensions in Safari preferences. I also used GlimmerBlocker (a system preference/launch agent/launch daemon) and I reinstall and finally disabled it along with the extensions. I also found several older add-ons in Application Support and deleted them. None of this helped.
5. I still use Safari Cookies, found in Application Support. I didn't try disabling it because I'm not sure I wish to lose several years of data that it has collected. Maybe it just recreates data as needed, I’m not sure. I suppose I could disable it as a last resort.

So, I'm still at a loss.

bobtomay 12-12-2013 07:14 AM

bump due to moderation

Lifeisabeach 12-12-2013 09:23 AM

Quote:

Originally Posted by matrixbud (Post 1555241)
5. I still use Safari Cookies, found in Application Support. I didn't try disabling it because I'm not sure I wish to lose several years of data that it has collected. Maybe it just recreates data as needed, I’m not sure. I suppose I could disable it as a last resort.

I use Safari Cookies myself (are you on the latest, 1.9.8?). It sounds like you know what you are doing, but.... you do have the cookie for mac-forums.com set as a favorite, right? You should also try removing all non-favorites for laughs. Worst case scenario, you may have to try uninstalling Safari Cookies and start over. Something is blocking the forum's cookie from being saved.

Here's something to try. You said you don't see the login stored in Keychain Access? Double-check: open it up; select "Passwords" from the Category panel; then enter mac-forum in the search box. If it still definitely isn't there, then run Keychain First Aid from the menu.

Also download Onyx and run its full suite of maintenance and cache cleaning tools. Perhaps there's some weird permissions bug here, or a faulty cache item.


All times are GMT -4. The time now is 06:38 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.