Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   Logic installation using 100% CPU and doing nothing (http://www.mac-forums.com/forums/os-x-apps-games/306030-logic-installation-using-100-cpu-doing-nothing.html)

cowbrain 11-24-2013 04:35 PM

Logic installation using 100% CPU and doing nothing
 
Hello all.

Hope I'm not in the wrong sub forum.

Bought a Macbook Pro (used).
Updated Mountain Lion - no problems.
Installed Logic Pro X. No problems, until nearly finished, when it asked for my password.

I hadn't got the password from the seller. I called him, but he took hours to respond.
Meanwhile, I went in and changed password, using terminal 'reset password' etc. (involving restart)

Now, Logic Pro X opens it's installer, asks for my password, accepts it, then does nothing. (I've waited hours)
Activity monitor shows that it is running, but no progress in the download/installation bar.

Have I wrecked things by changing my password halfway through?

(Word for Mac downloaded fine. Other software, too.)

Any thoughts appreciated.

Thanks, CB

(PS got the original password eventually - but now redundant) (this MBP is high enough spec for Logic)

cowbrain 11-24-2013 06:39 PM

Some hours and a couple of vodkas later, still musing on this..

I've never fully understood the Keychain process.
Wondering if I've confused the installer, by changing passwords mid-install?

When the (Apple) window came up, asking me for my password: I could nothing else but answer, or I would get the bong sound. When I clicked cancel, the whole Logic installer quit.
Now, when I try to install Logic, it asks for the password immediately - accepts my new password - then hangs and eats up (total) CPU.
Is it trying to continue from where it left off?
Can I get it to start from the beginning again?

Patience is a virtue, but there are also better things to do.
It's a decent Sunday night in England.
Wishing I'd had enough cash to go to the Apple store and buy a new one!
Thanks.

leadfoot 11-24-2013 06:58 PM

First off how big is the app itself. Do you have enough space for complete load when expanding the software. Is the software okay to work with the OSX 10.6 above. There are normally two passwords 1 for administration the second a guess user. Also the software issued will have a serial number issued to be added for use. On certain software you may need to add your administration twice first on installation and second after to adapt the system. Pending on the software size rams or Osx version the loading could be slowed by time need to fully complete if any other software is running. CPU sound like it being occupied fully due to the system itself need adjusting to compensate.
1. check that you have no other heavy apps running.
2. Disk Utility and repair any permissions.
3. Check enough space.
4. Try again

cowbrain 11-24-2013 10:35 PM

Thanks, leadfoot.

Yeah, HDD is 1TB - and empty. Logic Pro X only needs 5GB.
Software demands a minimum of 10.8.3 (achieved)
Nothing else running at all.

I take your point re two passwords - but password was not requested at start of install, only near completion (96%). No log in required, either. Seller supplied it with a clean install, with programs ready to install.

Uh oh. Didn't like the sound of that last sentence!
Might I have been scammed? Illegitimate programs?
All seemed legit.

Thanks for advice, though.
Will persist.
Best, CB

pigoo3 11-24-2013 11:37 PM

If installing Logic caused the problem...what happens if you uninstall Logic?

Installing a professional app like this really shouldn't cause this (versus a less established app). This is why I would want to verify that uninstalling Logic makes the problem go away. If the problem remains after removing Logic...then Logic isn't the problem...and it's something else.

Probably the only reason installing an app like Logic would cause this sort of issue...would be if the installer of Logic came from a "questionable" source.

- Nick

leadfoot 11-25-2013 05:27 AM

Hello Cowbrain.
I noted from your signature you're running osx 10.6.8 when the minimum for the Logic is osx 10.8.3. This might cause an issue with loading normally as this would alert you by the installation stage.

cowbrain 11-25-2013 06:35 AM

Many thanks for replies.

Nick. The problem is that it's not actually installed yet, so I can't uninstall it?
The only reference to Logic I can find, in a search of the machine, is the installer itself.
The 'questionable source' version of events could be right. Been back in touch with the seller a couple of times, but now he's gone quiet.
Re uninstall: I remember using the add/remove programs utility on Window$ machines. Any similar Mac equivalent? Or just find it and pull it into the trash?

leadfoot. Thanks again. The Logic is going onto a different machine than my signature MB. The newer machine exceeds all Logic's system requirements.

Thanks again.

leadfoot 11-25-2013 08:22 AM

Have a search on finder plist in system library as they can have a residue. Other than that you might have a dud software. Did you pay a lot of money because i looked on App Stores and the price is 139.99 for the latest version 10.0.4 as a digital download.

cowbrain 11-25-2013 09:05 AM

Thanks, leadfoot. I'll do that.

Will have to report back later. This MBP is for my daughter and she's taken it to university, today.

The software came with the MBP. I bought it from the classifieds in our local online paper.
Other software included (Micro$oft Office for Mac. Final Cut Pro) seem legit and loaded up without issue. (We put them on after we'd changed the password, so had no problem when the installs asked for password verification).
I realise that I may have to bite the bullet and fork out another 140 for Logic - but I need to be doubly sure, before I do this. (Money is very tight, just now!)

Anyone know a sure way to check the validity of this software? Do I just contact Apple support?

I'll get my hands on the machine again, tomorrow. I'll keep this thread updated with any developments.
May even put OSX Mavericks on it, too - while we're at it.

Thanks again.
Still welcoming suggestions.
Regards, CB

cowbrain 11-27-2013 08:36 AM

Fixed. But odd.

Tried repairing discs and permissions. Tried deleting plists (but couldn't find many appropriate plists). Tried installing in safe mode, no joy.

In the end we decided it must be an illegitimate copy. Went to the Apple store and bought a new copy.

Pushed install and the install/download bar went straight to 96% (where it had hung previously) and asked for the machine's password (Exactly the same pattern as before). Put the password in and the install finished in around two minutes!

So, it's all in there now and working perfectly. Cost me an extra 140, I could have done without spending. But at least we know it's the real deal.

Thanks for all the replies and suggestions.
Hope I can return the favour someday.
Best regards, CB

leadfoot 11-27-2013 10:47 AM

A salutary lesson of "if it to good to be true then it is". Are you able to retrieve the cost from the previous seller who may have sold a dud version? Best to keep to Black Fridays and App Stores.

pigoo3 11-27-2013 10:59 AM

Quote:

Originally Posted by leadfoot (Post 1552899)
A salutary lesson of "if it to good to be true then it is". Are you able to retrieve the cost from the previous seller who may have sold a dud version? Best to keep to Black Fridays and App Stores.

Not exactly...no one is going to get any "killer deals" on Apple hardware on "Black Friday"!;)

If the apps or anything else on this computer were questionable...a complete hard drive wipe, reformat, and a fresh OS install would have probably solved everything.

As long as the hardware was 100% fine...and the price paid for the computer was fair...everything is good.:)

- Nick


All times are GMT -4. The time now is 03:19 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.