Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   Reset/reinstall broken Mail.app in Mavericks (http://www.mac-forums.com/forums/os-x-apps-games/305566-reset-reinstall-broken-mail-app-mavericks.html)

edokid 11-12-2013 12:44 PM

Reset/reinstall broken Mail.app in Mavericks
 
Hey all,

I had gmail set up in Mail.app on my Mac when it had Mountain Lion and it worked okay but deleted the accounts. Upgraded to Mavericks but had issues non stop, not the ones everyone describes, but ones where I'd add the account, and nothing would happen, no folders show up no mail nothing. Sometimes I'd be able to get it to work but would always break. I wanted to erase all the preferences so online said to go to Library/Containers and delete the com.apple.mail folder which I did. When I stated Mail it was like it was new, I added my gmail account etc, customized the tool bar and all seemed to work. When I closed the app and re-launched it later my accounts were gone, so I had to set them all up again. Later when restarting it, the tool bar was back to the default even though my accounts were there. So something is messed up and it's constantly erasing the settings and so on. Is there any way to properly reinstall it without reinstalling my machine? I have time machine backups but they all started from after Mavericks only a few weeks ago. Just wondering if I'm basically screwed or if there's a proper way to reset it all back to defaults or what I can do? Thanks!

harryb2448 11-12-2013 04:43 PM

Have you used Software Update to download the update for Mail specifically for gmail users?


http://www.mac-forums.com/forums/os-...ail-1-0-a.html

edokid 11-12-2013 04:53 PM

I did yeah, it says it was auto installed October 30th. The issue I'm having though isn't any of the issues that that says it fixes, it's more that even if I just have iCloud set up for email, certain customizations like tool bar and so on revert back when I restart the app so something seems broken. So was wondering if there's a way to reinstall the app but assuming not..

stef0668 12-07-2013 03:19 AM

Same problem - still no fix
 
I have the exact same problem. Since I went to Mavericks my mail app is dead.

I can still see that there are accounts linked but none opens. I cannot rebuild or anything. I have one large email base which serves as my archive and a Gmail account attached to it.

I have the update with the gmail bug fix but to no effect.

I can also see that that there is still data in my invisible mail folder but I cannot get to it.

Is there any way to reset the whole thing and then retrieve from these folders?

Please help! I'm starting to go crazy without a real email client.

RobertM 01-30-2014 07:26 AM

I don't know the minimum number of steps required to do a clean restart of Apple Mail in Mavericks, but the combination of the following worked for me.

1. I closed Mail

2. I renamed or moved the files listed here for cleaning up plists and caches under Lion: mail.app - How do I reset Apple's Mail, in Lion, to default settings? - Ask Different

3. I did a Force-Quit of the cfprefsd process, as described here: objective c - Deleting plist file does not reset app on Mac OS 10.9 Mavericks - Stack Overflow

4. I renamed or moved the folder .../Library/Containers/com.apple.mail

It seems that the caching and this Containers folder are the differences of Mavericks compared to previous versions. I haven't investigated whether it is really necessary to touch the .../Library/Preferences folders, since possibly these plists are not being used now.

Without doing step 4, my Mail would hang when trying to start up....

wprl 02-17-2014 01:50 PM

Thank you
 
Step 4 solved my issue:

After using Migration assistant to transfer files to my new laptop, mail would not recognize the accounts registered in the Internet Accounts preference pane. By closing mail, deleting ~/Library/Containers/com.apple.mail everything is working again.

William Riley-Land
REST API Engineer
https://linkedin.com/in/willprl

wprl 02-18-2014 01:41 PM

Actually, it fixed it for a while, but now Mail can't find the accounts from Internet Accounts again. Some of the accounts in there have disappeared as well... I tried repeating step 4 again, but it didn't fix the issue this time.


All times are GMT -4. The time now is 12:37 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.