Results 1 to 5 of 5
  1. #1


    Member Since
    Nov 05, 2013
    Posts
    65
    Xcode for Mac Os x Snow Leopard 10.6.2
    Hey community, please can you tell me what is the best version of xcode for Mac os x snow leopard 10.6.2?

    Xcode 5 and 5.1 dont work or install because i think my mac version needs a older version of xcode.

  2. #2

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,948
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone7, Apple Watch, iPad Pro 9.7, AppleTV (4)
    If you a registered developer with a free account you can get xcode 3.2.6 and SDK 4.3 for Snow Leopard. If you have a paid for developer account you can get xcode 4.2 for Snow Leopard.

    Both, depending on yopur account, can be download from here under 'Additional Downloads'
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  3. #3


    Member Since
    Nov 05, 2013
    Posts
    65
    So, xcode 3.2.6 has the iphone sdk already installed? If not, how do i download it seperately?

    Iphone sdk 4.3 is available for both xcode 3.2.6 and 4.2 right?
    Because when i launch xcode 3.2.6 in my mac os x 10.6.2 snow leopard, then i dont see the option to choose iphone sdk . I only see the mac os x sdk and get to choose option within the mac os developing toolset ONLY. not the iphone ios dev toold in xcode 3

  4. #4

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,948
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone7, Apple Watch, iPad Pro 9.7, AppleTV (4)
    If you look at the description in the downloads section linked above it tell you exactly what's included.

    You can't copy and paste for that page so here's a screen grab.
    Attached Images Attached Images
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  5. #5


    Member Since
    Nov 05, 2013
    Posts
    65
    Thanks, i have found the download, but cant i download the IOS 4.3 sdk by itself and NOT the xcode 3.2.6 again since i already have the xcode AND dont wish to use up bandwith to download another 4GIGABYTES,.

  6. #6


    Member Since
    Nov 05, 2013
    Posts
    65
    Do you think my OS for mac will be able to execute any later release of xcode 3.2.6?

    Say if i wanted to use xcode 4 or xocde 3.2.7 or xcode 3.4.0/3.4.1/3.4.2/3.4.4?
    Thanks.

  7. #7

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,948
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone7, Apple Watch, iPad Pro 9.7, AppleTV (4)
    As per the screen grab you have everything you need in the download you already have.

    I you can't see the iPhone dev option, that's a little odd. Perhaps post a screenshot?

    I'm not sure what your goal is (self-interest, learn objective c etc) but if you're wanting to develop for submission to the app store the minimum requirements are (taken from the iOS dev site):
    To develop iOS apps, you need:
    • A Mac computer running OS X 10.7 (Lion) or later
    • Xcode
    • iOS SDK
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  8. #8


    Member Since
    Nov 05, 2013
    Posts
    65
    Yes i have xcode i just want to download the ios sdk seperatly since i do not wish to waste firther 4gb of download data or my bandwith.
    Dont worry i have it now.
    I want to know, that in this version of xcode you told me of, is it possable to progarm any socket progarms such as skype or internet apps such as browsers, p2p programs running in ios iphone. I know objective c and i can make a hello world app and code windows api window in c. I recall everything and i dont think that i need to look back at documentation.

  9. #9

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,948
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone7, Apple Watch, iPad Pro 9.7, AppleTV (4)
    From a capability point of view you'll need to look at the API reference for iOS4.3. I kind recall at which point those features were made available to devs.
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  10. #10


    Member Since
    Nov 05, 2013
    Posts
    65
    Ok thank you.
    Again thinking about socket programming, i mean using TCP/IP components and not just using the Rapid app dev environment, i also want to write code for them. Is that objective c or some other RAD language?

  11. #11


    Member Since
    Nov 05, 2013
    Posts
    65
    will xcode 3.2.6 with ios sdk 4.3 work with mac os x 10.6.8?
    I know that i had 10.6.2 but now i have upgraded using mac os x software updates.
    So do you know if i am able to download a later version say 4.1 or or 4.0/4.2???
    I have a free account NOT a piad acc at mac dev website.
    Thanks

  12. #12

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,948
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone7, Apple Watch, iPad Pro 9.7, AppleTV (4)
    Quote Originally Posted by raghavsood999 View Post
    will xcode 3.2.6 with ios sdk 4.3 work with mac os x 10.6.8?
    I know that i had 10.6.2 but now i have upgraded using mac os x software updates.
    So do you know if i am able to download a later version say 4.1 or or 4.0/4.2???
    I have a free account NOT a piad acc at mac dev website.
    Thanks
    Nothings changed since my post above: http://www.mac-forums.com/forums/os-...ml#post1548541
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Old-style Mac OS X Leopard Exposť in Snow Leopard
    By iggibar in forum OS X - Operating System
    Replies: 2
    Last Post: 01-10-2011, 04:59 PM
  2. Upgrade from Leopard to snow Leopard in Mac Pro
    By wil in forum OS X - Operating System
    Replies: 4
    Last Post: 09-15-2010, 03:24 AM
  3. how to install xcode on mac leopard
    By midnight12 in forum OS X - Development and Darwin
    Replies: 7
    Last Post: 04-09-2010, 05:45 PM
  4. 32 bits on Snow Leopard : old dylib, dylib paths and xcode
    By milou645 in forum OS X - Development and Darwin
    Replies: 1
    Last Post: 11-01-2009, 08:22 PM
  5. Snow Leopard and Leopard 10.5.8 back to my mac
    By whitty in forum OS X - Operating System
    Replies: 1
    Last Post: 10-07-2009, 11:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •