Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,977
    Specs:
    Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
    Simple Excel problem - number pad giving directions
    Out of the blue, my number pad switched from giving numbers to navigating around the spreadsheet. That is, the 2 | 4 | 6 | 8 keys function like arrow keys. I know the answer is staring me in the face, but I can't see through the egg.

    I've looked at my keyboard, tried the Insert key, looked through Excel preferences too. I can't find the right key or button to hit. Help! I want numbers; I have arrow keys already.

  2. #2

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,977
    Specs:
    Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
    Wow! No one on this forum uses Excel?

    New information: I noticed that the number pad works fine in Calculator. So, I opened a Numbers file, and it worked fine there too. It has to be an Excel thing.

    Also, I did mess with the Num Lock key, but that did not change anything. I'm not sure my Num Lock key does anything at all. There is a light on the keyboard for it, but that is always off, no matter how many times I hit Num Lock. The light goes off and on for Caps Lock however.

  3. #3

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    47,067
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    I have Office installed but no longer mess with Excel. I'm strictly a Word and Powerpoint user. However, it does sound like your keyboard may have gone south on you. Do you have another you can try, one with a numeric keypad? Also, you might try a SMC and PRAM reset although I don't think either will work if the keyboard is having problems.

  4. #4

    MYmacROX's Avatar
    Member Since
    Mar 17, 2009
    Posts
    3,625
    Specs:
    2008 15" MBP Yosemite, 2012 21.5" iMac Yosemite
    You have Num Lock turned off. That lets you use the 2, 4, 6, 8 as arrow buttons.

    This only works if Scroll Lock is off and Num Lock is off.
    64GB iPhone 6, 64GB iPad Air 2.

    Reminder: Please include your Mac's specs. This will make it much easier for the other members to assist you.

  5. #5

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,977
    Specs:
    Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
    Thanks for the input. I'll play around with those tonight and see if I can get it to behave. The interesting thing is that in Numbers, I get numbers... without touching Num Lock after just getting arrow key behavior in Excel. I do not have a spare USB keyboard to try, unfortunately.

  6. #6

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,977
    Specs:
    Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
    No luck. No matter what I do with Num Lock and Scroll Lock, the number pad is stuck in "arrow mode" in Excel. Yet I still can get numbers out of it in Numbers. This must be an Excel issue. As I've used the number pad in Excel for years, some setting must have gotten changed. I have not installed anything new in quite some time, so that's ruled out. This is very puzzling, and annoying.

  7. #7

    MYmacROX's Avatar
    Member Since
    Mar 17, 2009
    Posts
    3,625
    Specs:
    2008 15" MBP Yosemite, 2012 21.5" iMac Yosemite
    Well, that's how I figured it out by playing with it on my work computer.

    Windows 7 Enterprise with Excel 2007 using a standard HP keyboard. Maybe the Num Lock or Scroll Lock key is broken and stuck in the "Off" option.
    64GB iPhone 6, 64GB iPad Air 2.

    Reminder: Please include your Mac's specs. This will make it much easier for the other members to assist you.

  8. #8

    nickyr's Avatar
    Member Since
    Nov 01, 2007
    Location
    Swansea - South Wales
    Posts
    724
    Specs:
    late 2012 IMac 27", early 2015 MBPr, early 2014 MBA, mid 2010 MB (10,11.3), iPhone 6 (iOS 9).
    could this be your problem?

    OS X Lion: Shortcuts for Mouse Keys
    nobody expects the Spanish inquisition...


  9. #9

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,977
    Specs:
    Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
    Quote Originally Posted by nickyr View Post
    could this be your problem?

    OS X Lion: Shortcuts for Mouse Keys
    Well, I'm using Leopard, but I'll look into this. Thanks!

  10. #10

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,977
    Specs:
    Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
    Quote Originally Posted by MYmacROX View Post
    Maybe the Num Lock or Scroll Lock key is broken and stuck in the "Off" option.
    That could explain why I'm having this problem in Excel. But, it wouldn't explain why I'm not having the problem in Numbers.

    (Come to think of it, neither would the suggestion in the link in that other post...)

  11. #11

    cradom's Avatar
    Member Since
    Feb 14, 2004
    Location
    Groves, Texas
    Posts
    4,401
    Specs:
    13in macbook - 10.11 --- 21in. iMac 10.11 --- HP win 8
    Try pressing shift-clear, or shift-F14, depending on the keyboard.
    Always listen to experts. They’ll tell you what can’t be done and why. Then do it!
    -Lazarus Long

  12. #12

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,977
    Specs:
    Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
    Well, I can give that a try. Is this some sort of keyboard shortcut for something?

  13. #13

    cradom's Avatar
    Member Since
    Feb 14, 2004
    Location
    Groves, Texas
    Posts
    4,401
    Specs:
    13in macbook - 10.11 --- 21in. iMac 10.11 --- HP win 8
    It's an Excel shortcut. Changes numpad from input to directional and back.
    This is so you don't have to remove your hand from the keypad.
    Always listen to experts. They’ll tell you what can’t be done and why. Then do it!
    -Lazarus Long

  14. #14

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,977
    Specs:
    Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
    Quote Originally Posted by cradom View Post
    Try pressing shift-clear, or shift-F14, depending on the keyboard.
    Well I don't have a "clear" key or F14, but Shift-NumLock did the trick!

    Now the real trick will be remembering that the next time it accidently gets switched a year or two from now.

    Thanks for the inspiration!

  15. #15

    cradom's Avatar
    Member Since
    Feb 14, 2004
    Location
    Groves, Texas
    Posts
    4,401
    Specs:
    13in macbook - 10.11 --- 21in. iMac 10.11 --- HP win 8
    Glad you got it. Must be using an older keyboard? On my old Macally Numlock/Clear is the same key and is marked as such.
    Always listen to experts. They’ll tell you what can’t be done and why. Then do it!
    -Lazarus Long

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Excel for Mac giving me #VALUE! for everything
    By glossolalia in forum OS X - Apps and Games
    Replies: 3
    Last Post: 06-12-2011, 08:31 PM
  2. Is it possible to program the number pad?
    By LCSterling in forum Apple Desktops
    Replies: 1
    Last Post: 08-11-2010, 10:51 PM
  3. Number pad or not?
    By wrongmark2 in forum Other Hardware and Peripherals
    Replies: 4
    Last Post: 10-26-2009, 12:48 PM
  4. Faulty number pad on keyboard!
    By johnnytentoes in forum Apple Desktops
    Replies: 2
    Last Post: 10-09-2008, 07:05 PM
  5. number pad not working
    By Greyspot Design in forum Apple Desktops
    Replies: 1
    Last Post: 01-29-2008, 04:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •