Results 1 to 5 of 5
  1. #1

    Member Since
    Aug 28, 2004
    SSH in Terminal, cursor goes crazy and overwrites text
    I SSH into my hosted PBX all the time and in Windows I use Puddy and have zero problems. On the mac I Just use SSH from the Terminal. For the first maybe 15 minutes it works totally fine, and usually stays fine on the command line etc. However if I'm in an image editor like Nano, if I'm moving the cursor around, it starts erasing things. Or lets say I want to type the word "phone" it will write something like:

    p ^3NE

    If I press backspace to erase it, then it will erase it all, I press H and it writes the ^3NE again. Usually logging out and back in fixes it. I downloaded a trial of a 3rd party terminal app and it didn't do this either. Is there something wrong with the mac terminal?

  2. #2

    Raz0rEdge's Avatar
    Member Since
    Jul 17, 2009
    27" i7 iMac, 24" iMac, 13" Macbook Air, iPhone 5 & 5S, iPod Nano 7th Gen, iPad 2 16GB WiFi, iPad 3
    It's probably an issue with the terminal type. Going through PuTTY (not Puddy ) you're probably using the sane VT100 or something, but the OS X terminal might be using something else that doesn't jive with your remote host..

    Be sure to read the Community Guidelines | The more information you provide, the better answers you get, remember GIGO.

  3. #3

    Dysfunction's Avatar
    Member Since
    Mar 17, 2008
    Tucson, AZ
    Way... way too many specs to list.
    Yep, it's probably an emulation issue. When you connect do something like..

    export TERM=vt100

    and try that. By default, terminal uses xterm-256color, which may not be the most friendly when it comes to editors. I've seen similar emulation issues as well. (with other product actually)
    This machine kills fascists
    Got # ? phear the command line!

  4. #4

    Member Since
    Aug 28, 2004
    Oops sorry meant Putty haha.

    Do you know where I type that?

    Right now I do: ssh -p 20022 root@ for example.

    I tried ssh -p 20022 root@ export TERM=vt100

    Which asks for my password like normal but after I enter it, it just goes back to my Mac command prompt. Doesn't say invalid password or anything just does nothing. Tried putting it after the -p 20022 but then gives an error?

  5. #5

    Member Since
    Aug 28, 2004
    Actually I just noticed under the settings for Terminal it has emulation type and shows vt100 and it was on the xterm-256 so I'll try changing there too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. crazy cursor
    By happy in forum Apple Notebooks
    Replies: 5
    Last Post: 08-28-2012, 09:16 PM
  2. SSH with Terminal
    By Basil Fawlty in forum Switcher Hangout
    Replies: 7
    Last Post: 06-02-2011, 05:52 PM
  3. BRAND-NEW MacBook Pro cursor going crazy
    By sofie in forum OS X - Operating System
    Replies: 7
    Last Post: 03-28-2011, 06:37 AM
  4. SSH Login w/ Terminal
    By PrimalYeti in forum OS X - Development and Darwin
    Replies: 1
    Last Post: 07-27-2009, 11:13 PM
  5. Problems with terminal SSH compiling.
    By monolith in forum OS X - Development and Darwin
    Replies: 7
    Last Post: 01-16-2009, 11:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts