Mac Forums

Mac Forums (
-   OS X - Apps and Games (
-   -   Skype DMG wont mount (

Mack Neaton 01-16-2012 06:54 PM

Skype DMG wont mount
I have multiple dmg's on my desktop all of which mount except one. Skype.
I am running Mac 10.4.11 and there is multiple articles on the internet where dmg's wouldn't mount but it was too wide ranged. I downloaded an old version of skype for 10.4.11 via mac.old-apps. And the worst part is: Its worked fine in the past. I've mounted it previously but i was new to Mac and never copied the application into the Apps folder. One day i got on and it just wouldn't mount. I would click on it and it would look like it was going to open but it wouldn't.
I have a eMac PowerPC g4 processor if it matters

chas_m 01-18-2012 05:04 AM

I'm sorry, why would you ever need to mount a dmg more than once?

Mack Neaton 01-18-2012 02:39 PM

"I've mounted it previously but i was new to Mac and never copied the application into the Apps folder."
I didn't know what it was asking me to do so i would just double click on the icon and Skype would open. Since then I have figured out what it was asking but i cant now because the dmg wont mount. Hence the question.

cradom 01-18-2012 02:49 PM

It might be corrupted. Try downloading it again.

Mack Neaton 01-18-2012 02:59 PM

already did. twice

CrimsonRequiem 01-18-2012 04:30 PM

Is Skype open? If so then do the following:

Quit out of it and then eject the Skype icon on your desktop. Mount the Skype dmg. Drag and drop into your applications folder.

Mack Neaton 01-18-2012 04:32 PM

except for the fact that it wont mount

CrimsonRequiem 01-18-2012 04:42 PM


Originally Posted by Mack Neaton (Post 1357494)
except for the fact that it wont mount

What version of skype are you trying to install?

Mack Neaton 01-18-2012 04:54 PM

version bc its compatible with Mac 10.4.11

CrimsonRequiem 01-18-2012 06:18 PM

Try this <= version and see if it works.

chas_m 01-19-2012 04:22 AM

The bottom line problem here is that you are not properly installing applications, you are trying to run them from the disk image, which as you've discovered is not correct.

Sometimes, DMG files mount PKG installers, and sometimes (as with Skype), the disk image opens to a pictorial representation of the program's icon and an alias to your Application folder. Drag the icon to the app folder and it will be copied to your Application folder.

Then you can eject the image and trash the DMG. You don't need them anymore.

From now you, you launch Skype from your Application folder, the Lauchpad if you use it, or by dragging the Application folder Skype icon to the dock and launching it from there.

This applies to all other downloaded programs.

Mack Neaton 01-22-2012 10:45 AM


Originally Posted by CrimsonRequiem (Post 1357532)
Try this <= version and see if it works.

I tried downloading it but when the download finished the icon in the downloads list turned into a white page and so when i click on it it said "Safari can't open the file "Skype" because no available application can open it." I found the downloaded disk image on my desktop and tried to open it but it did the exact same thing it did in my first post.

CrimsonRequiem 01-22-2012 01:53 PM

Have you tried downloading it with something other than Safari?

Mack Neaton 01-22-2012 02:01 PM

nah all I have is Safari and Light Browser bc i couldnt find a browser i liked that supported PPC with 10.4.11
Im currently trying to download using TenFourFox (Firefox)
Nope didn't work. When I opened it from the downloads list though, it said it was verifying and checking volumes and stuff, and at the end it said "Mounting" but when the dialogue box closed, no disk image

cradom 01-22-2012 02:55 PM

Do a get info on the .dmg. Does the 'Open with' say DiskImageMounter?

All times are GMT -4. The time now is 12:25 AM.

Powered by vBulletin
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.