Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   Some apps only work with root user account (http://www.mac-forums.com/forums/os-x-apps-games/262028-some-apps-only-work-root-user-account.html)

vinkadog 12-30-2011 05:39 PM

Some apps only work with root user account
 
Hey there, new to the forum. I have a MacBook running OS X 10.6.8. I've had a problem with some apps that simply do not work with my regular user account; they will only work if I log in with a root user account. I have tried allowing incoming connections for these apps through System Preferences/Security/Firewall/Advanced/ and it still doesn't work.

Specific examples:

Netflix: in my regular user account, I go to Netflix through Safari and get Silverlight Application Storage Error N8010. If I log in under the root user account I have no problems. I'm pretty confident it's not a Silverlight problem since it works in the root user account.

Mac App Store: In my regular user account, I can't download any apps. I click on an app's Install button and the the wheel just spins and nothing happens. I tried clearing the cache through iTunes, logging out/logging in, restarting--nothing. In the root user account download starts immediately.

Evernote: I couldn't even download this in my regular account (see Mac App Store above), so I downloaded it through my root user account. When I launch Evernote in my regular user account, it quits unexpectedly. (I can post the entire message if needed.) In my root user account, it opens just fine.

Adobe Digital Editions: For the longest time I could not use ADE in my regular user account--it would quit unexpectedly. It always worked in my root user account, so I would download library books there and transfer them over to my Nook. Today ADE suddenly started working in my regular user account.

For Netflix and ADE it wasn't too big a deal to log in on the root user account. But with Evernote, I absolutely want to be on my regular user account. I'm guessing there's a security setting somewhere that is checked wrong--but where?

Any ideas? Thanks in advance!

RavingMac 12-30-2011 06:12 PM

Go to System Preferences>Users&Groups
Click on your login account and then click the padlock in the lower left corner to allow changes.
See if Enable parental controls is checked. If so, uncheck it. Also make sure you have Allow user to administer this computer checked too.

vinkadog 12-30-2011 06:16 PM

Enable parental controls was already unchecked. Allow user to administer this computer was already checked.

Any other thoughts? Thanks!

louishen 12-30-2011 06:20 PM

Have you tried simply doing a permissions repair in disk utility

vinkadog 12-30-2011 06:27 PM

No, I haven't. I just read up on permissions repair at the following link, and I'll be honest--I have no idea what it says to do. Is there a simple "go to this, check this box etc" type of list that I can follow? Thanks!

About Disk Utility's Repair Disk Permissions feature

vinkadog 12-30-2011 06:31 PM

Never mind, found it. Repairing permissions through Disk Utility is underway, and should take about 30 minutes. Will report back.

RavingMac 12-30-2011 08:40 PM

If that doesn't work you can also try doing an SMC and PRAM reset. That will often fix strange problems.

vinkadog 12-30-2011 09:23 PM

OK, a report:

-I tried Permissions Repair via the Disk Utility. The first time it brought up a laundry list of repairs and said it would take 30 minutes. After about 10 minutes or so it stopped, and the time remaining never budged. I hit Permissions Repair again and it said 22 minutes...I hit it several times more and the time remaining decreased: 19, 17, 16....then increased again to 20, 30. Then I stopped.

-I tried a PRAM reset. No difference.

-I tried an SMC reset. It didn't fix the problems that this thread is about, but it did help with an intermittent flickering monitor that is now better! So thanks for that--but alas, the original problem remains.

More ideas welcome! Thank you!!

Slydude 12-30-2011 09:39 PM

Shot in the dark but here goes. We know the programs work when run as root user but that's not a good solution. Try creating a new user account and allow it to administer the computer. Do the programs run when logged into that account? If so that would suggest either bad preference files for those programs or conflict with something else specific to your account.

Also, while repairing permissions did you verify the disk as well? I'm curious about why you are unable to repair permissions.

vinkadog 12-30-2011 09:45 PM

Regarding the Permissions Repair--when I am in Disk Utility, I see Verify Disk Permissions, Verify Disk, and Repair Disk Permissions (Repair Disk is grayed out). All I have tried is Repair Disk Permissions. Should I try Verify Disk Permissions and Verify Disk? Does the order in which I perform them matter?

vinkadog 12-30-2011 09:54 PM

OK, just created a new user account--made it an admin, allowed user to administer this computer. Both Evernote and Netflix work! I'm feeling totally slighted that there's an anti-me bias going on here....so how I do I track down the conflict?

XJ-linux 12-30-2011 09:56 PM

Have you messed around as the root user before and actually installed applications as root? I know on Unix systems that if an application is installed as root, with certain flags present, the permissions and file paths become set such that only root has access to some of the components needed to run the application. I've seen this happen in SAP when root is used to install components because the person doing the installation doesn't like that the sapadm or oraadm user has to keep typing in "sudo command" every few minutes. The install works, but won't run right because log files, binaries, etc are all owned by the wrong user/group or pathed to the wrong home directory. I've also seen where components were installed in a "root" or system directory instead of a user or common directory. The base directory structure ends up prohibiting others from using those applications because, while permissions are correct on some files, not everything is accessible at the directory level.

Short of it... sounds to me like root or a member of another group owns parts of your applications, was probably used to install certain things, may have altered base permissions on files used by other applications in general, or that those applications are using directories and files they have no access to in their course of operations. Alternatively, your regular user account could also be a member of some obscure or custom group that doesn't play well with "normal" installations.

You may wish to try downloading the an application that doesn't work all over again (as root if you can't as your regular user). While still root, just change the permissions to something like 777 or 775 and make sure the group is "admin" or "staff" and not "wheel" or "system". Place the installer in a common directory, or better yet your main user's home directory. Then log out of the root account and log back in as your user. Try the installation again. If it works properly this time, then we are on the right track. If it doesn't then it could mean that something is services or the like is buggered up.

vinkadog 12-30-2011 10:05 PM

I installed ADE under my regular user account--it just wouldn't work properly unless I was logged in as root user.

I installed Evernote through the Mac App Store on the root user account. Evernote works in the root user account, and in the new user account I just created, but not in my regular account. So if your idea were correct, Evernote wouldn't work in the new user account--but it does.

Also, Netflix streaming works in both root user and the new user account, but not in my regular user account. That's through Safari and not a separate app.

So I see where you're going, and it's a logical guess--but I don't think that's the case here, given the new user account's ability to use these apps. Great ideas though, and thank you!

XJ-linux 12-30-2011 10:10 PM

No worries. Have you looked at the console log? You may see some information stating things like "couldn't write to directory" or "unable to access...". Anyhow, good luck.

ETA: do your old user account, and new user account have the same group memberships as viewed in the terminal?

vinkadog 12-30-2011 10:28 PM

Checked the console log--see below. I am definitely over my head in interpreting this, so any guidance is appreciated:

12/30/11 7:56:07 PM Evernote[180] Unable to initialize logging: Error Domain=NSCocoaErrorDomain Code=513 UserInfo=0xa21ca0 "You don’t have permission to save the file “Evernote” in the folder “Application Support”." Underlying Error=(Error Domain=NSPOSIXErrorDomain Code=13 "The operation couldn’t be completed. Permission denied")

I don't know how to check the terminal for group memberships. Or what that means, even. Did I mention that I'm a chef? So I can whip up a mean sabayon for ya.....anyway!

My life partner suggested another course of action--as the root user, make my main/malfunctioning user account Not An Admin, then make an Admin. Since the new user account I created got the correct permissions, maybe this reset will make my regular user account behave correctly. And if that doesn't work, I have some chicken bones and the number of the local voodoo doc handy.


All times are GMT -4. The time now is 02:39 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.