New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

MS Office 2011 Date & Time format


Post Reply New Thread Subscribe

 
Thread Tools
bigjoshua

 
Member Since: Sep 21, 2011
Posts: 1
bigjoshua is on a distinguished road

bigjoshua is offline
I have very strange problem with MS Word 2011 ver. 14.1.3
Date/Time format is completely strange and out of sync with OS X Lion. In system preferences / Language and Text / Format -> Region selected is US.

Here is screen shot from Word / Insert / Date & Time

May be someone have idea how this issue can be solved/fixed?
QUOTE Thanks
slstern

 
Member Since: Sep 22, 2011
Posts: 3
slstern is on a distinguished road

slstern is offline
I am having the same problem. I just upgraded to 2011. The problem started with 2008. It may have been a result of the switch to Lion; I can't remember if there was a correlation. I have been unable to figure out how to reset the date format in Word. The date and time format in Lion in the System Preferences is correct, i.e., it shows the entire year.

Help appreciated.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 39,660
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
Nothing strange, it's normal. In order to see the date - formats in Lion, open "Language & Text", and click on the Format tab. The date format is not found in "Date & Time". That's only used for setting the date - time for your machine according to your time zone locale.
QUOTE Thanks
slstern

 
Member Since: Sep 22, 2011
Posts: 3
slstern is on a distinguished road

slstern is offline
Thanks, chscag, but the problem in Word persists.

I HAD verified the date format in Lion's Language & Text System Preference, thinking that's where the problem originated. However, while today's date in System Preferences reads "September 22, 2011", in the corresponding MS Word 2011 Date and Time window (shown in bigjoshua's original post), it still reads "September 22, 11". When using autotext to complete the date, Word has been dropping 20 from the year. In my case, it was going on before upgrading to Office 2011. I think it MAY have started when I upgraded to Lion, but I can't remember.

Thanks again for trying.
QUOTE Thanks
EvenStranger

 
EvenStranger's Avatar
 
Member Since: Dec 09, 2010
Location: Virginia
Posts: 845
EvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really nice
Mac Specs: Currently 13" Late 2010 MBA, 4GB/128GB; Early 2011 13" MBP, dual core i7 2.7ghz, 4gb ram, 500gb hd

EvenStranger is offline
Thanks for clarifying that - I missed it the first time as well. Mine's doing the same thing. I'll forward a request to our MS tech manager and see if we can get some guidance on it. I'll let you know if I find out anything.

http://support.microsoft.com/kb/2586538
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 39,660
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
Quote:
I HAD verified the date format in Lion's Language & Text System Preference, thinking that's where the problem originated. However, while today's date in System Preferences reads "September 22, 2011", in the corresponding MS Word 2011 Date and Time window (shown in bigjoshua's original post), it still reads "September 22, 11". When using autotext to complete the date, Word has been dropping 20 from the year. In my case, it was going on before upgrading to Office 2011. I think it MAY have started when I upgraded to Lion, but I can't remember.
Word is not dropping anything. It's the choice that Word gives when you select that particular format. It's plain and clear in the Word date and time dialog that it prints the date as "September 22, 11".

Now if you say that MS neglected to offer the date format of "September 22, 2011" you would be correct. And it appears MS Office is not using the date formats from System Preferences.

But, I agree with you about the format. They certainly should include that format since it's one of the more popular ways (at least in the US) to display the date. I'll report the omission to the MS Office forum on their server where perhaps one of the MS MVPs can comment or explain.
QUOTE Thanks
slstern

 
Member Since: Sep 22, 2011
Posts: 3
slstern is on a distinguished road

slstern is offline
Thanks, chscag. Please tell the MS MVP that I did not "select" that format. It just started happening one day when I was writing a letter with the date at the top and expected the normal "2011" to be added with the date after typing the month. I had not made any changes in my options, preferences, customizations, etc. I was using MS Word 2008 for Mac at the time. It has continued to be a problem since upgrading.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 39,660
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
The latest: According to MS, it will be addressed in a future service pack or update; whatever that means... Also promised are versions and save versions for Lion compatibility.

As a note, I just downloaded and installed an update for Office 2011 today but it appears to only be a small security patch, nothing major.
QUOTE Thanks
EvenStranger

 
EvenStranger's Avatar
 
Member Since: Dec 09, 2010
Location: Virginia
Posts: 845
EvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really nice
Mac Specs: Currently 13" Late 2010 MBA, 4GB/128GB; Early 2011 13" MBP, dual core i7 2.7ghz, 4gb ram, 500gb hd

EvenStranger is offline
Our Technical Accounts Manager at MS said the same thing... there are a bunch of documents referencing the issue, but no ETA on a solution. I told him we needed a solution in 30 days. We'll see how well that flies. :-)
QUOTE Thanks
skilletaudio

 
Member Since: Jan 05, 2012
Posts: 2
skilletaudio is on a distinguished road

skilletaudio is offline
Still no update to this over 3 months later. It doesn't follow system preferences and seems only to be a Lion issue since it works fine for me on Snow Leopard and follows Macs default settings.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 39,660
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
Why they didn't address it in the latest service pack (4) is beyond me. They still haven't fixed the "save" and versions for Lion either.
QUOTE Thanks
david19087

 
Member Since: Jan 12, 2012
Posts: 1
david19087 is on a distinguished road

david19087 is offline
My workaround:

In autocorrect, replace ", 12y" with ", 2012".

If MS completes to "January 12, 12" I just add "y " and the autocorrect takes care.

Not great, not terrible. Just MS at work, 'ya know
QUOTE Thanks
skilletaudio

 
Member Since: Jan 05, 2012
Posts: 2
skilletaudio is on a distinguished road

skilletaudio is offline
Quote:
Originally Posted by david19087 View Post
My workaround:

In autocorrect, replace ", 12y" with ", 2012".

If MS completes to "January 12, 12" I just add "y " and the autocorrect takes care.

Not great, not terrible. Just MS at work, 'ya know
Good idea thanks for sharing.
QUOTE Thanks
macintush

 
macintush's Avatar
 
Member Since: Jun 06, 2012
Posts: 1
macintush is on a distinguished road
Mac Specs: iMac (late 2006); OS X 10.7.5 (Lion)

macintush is offline
1. On your Mac, go to System Preferences; Language & Text [NOTE: **Mac** system prefs, NOT Word/Office prefs!]

2. Even if everything looks correct (ie, full, 4-digit year), under "Dates", click "Customize" and RE-set the "Medium", "Long", and "Full" date formats to the 4-digit year (eg, "2013") using the drop-down selection menu. Make sure the "Year" element (below the formats) shows all 4 digits (this doesn't seem to be changeable, but mine shows all 4 digits: "2013").

3. Click "OK"

4. Office now uses the 4-digit year when you "insert date".


Worked for me, using Lion (OS X 10.7.5) and Office:Mac 2008. I also had this problem appear out of the blue (red?) after upgrading from Snow Leopard (10.6.x) to Lion (10.7.x). Not sure if this will work for Office 2011 or Mountain Lion (10.8), but give it a try.

iMac (late 2006); OS X 10.7.5; Office:Mac 2008
QUOTE Thanks
MrTutt

 
Member Since: Jun 30, 2010
Posts: 35
MrTutt is on a distinguished road

MrTutt is offline
My MBP mid 2010 running ML was doing this as well. Really bugged me. Nice fix. It is working right now. Thanks.
QUOTE Thanks

Post Reply New Thread Subscribe


« OneNote vs EverNote on Mac and iOS | Adobe Premiere Elements 12...Crashing »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Office 11 Outlook Folder Issue Good.Spliff OS X - Apps and Games 7 05-27-2011 06:12 PM
Date and Time settings matt f OS X - Operating System 7 05-11-2011 10:58 PM
MS Office 2011 Jasonjason Switcher Hangout 4 07-20-2010 07:06 PM
Weird time and date changes LEOVAN83 iPod Hardware and Accessories 9 02-16-2009 05:21 PM
Date & Time memory on an imac confused imac Apple Desktops 1 02-09-2005 06:44 AM

All times are GMT -4. The time now is 05:27 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?