When i try and configure Freedroid RPG, i get this on the command line output

configure: Checking for compulsory SDL libraries:
checking for sdl-config... /sw/bin/sdl-config
checking for SDL - version >= 1.2.3... no
*** Could not run SDL test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means SDL was incorrectly installed
*** or that you have moved SDL since it was installed. In the latter case, you
*** may want to edit the sdl-config script: /sw/bin/sdl-config
configure: error: *** SDL version 1.2.3 not found! You need to install SDL to build and play FreedroidRPG. This includes the -dev packages on distributions that have them. Please refer to the README file.

I use fink and i know i have SDL installed, and the version is newer that 1.2.3, so why is it saying this and how do i fix it?