New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

iTunes sync with iPhoto showing multiple events


Post Reply New Thread Subscribe

 
Thread Tools
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
This started after I updated iPhoto to the latest version. Every time I try to sync my iPad 2 and go to the photos tab i have this issue (check image)

I only have 16 events but iTunes is showing at least 30+ because they are showing up twice and the event in iTunes don't even show the same number of pictures in each. I've tried deleting the file under

finder-pictures-iphoto-right click-show package contents-ipod photo cache and nothing works...

I found this on apple's site but no solution.

https://discussions.apple.com/message/15092468
Attached Images
File Type: jpg Screen shot 2011-04-28 at 10.06.40 PM.jpg (217.1 KB, 16 views)
QUOTE Thanks
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
No one has seen this before?
QUOTE Thanks
Buzzard2010

 
Buzzard2010's Avatar
 
Member Since: Oct 22, 2010
Location: Bretforton, Worcestershire
Posts: 2,573
Buzzard2010 is just really niceBuzzard2010 is just really niceBuzzard2010 is just really niceBuzzard2010 is just really niceBuzzard2010 is just really nice
Mac Specs: MacBook Pro 15" 2014, 2.2GHz i7, 16GB RAM, 250GB SSD, OSX 10.9.5 - iPhone 5s 16gb

Buzzard2010 is offline
Hmm that is a little strange, have you got more than one library in iPhoto? Or an old one that has not been deleted properly?
Hold down the "alt" key when opening iPhoto to see if there is more than one library registering.

Cheers
- Simon


If you have been helped, don't forget to use the Reputation system at the top right of their post.
May 2011
Nominated: March 2011 & April 2011
QUOTE Thanks
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
Simon,

I only have one library and when opening the app help the alt key down and only one library was registered. I'm stumped on this...looks like others have the same issue after updating.
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 25,192
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
Based on the thread in the apple forums, looks like it's showing a folder based not only on name, but on each date something was imported into a particular folder.

I may experiment if I get time this weekend to see if I can duplicate it and fix it or if apple is going to have to fix it.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
thanks Bob...I hope you can figure it out bc Apple will take their time.
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 25,192
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
Turns out it's pretty easy to duplicate.




Note: I still have iPhoto '08, so whatever version you have may be slightly different than mine. (I use Aperture instead of iPhoto.) This also goes to show it is more than likely the same across multiple versions of iPhoto.

The problem has nothing to do with iOS or iTunes. It is the way you're importing pics into iPhoto. You need to understand how iPhoto handles events. It categorizes them based not only by name, but by the date the pics were shot. So, you can have multiple "Events" with the same name, but iPhoto recognizes them as separate events when they are imported at separate times.

Just open up iPhoto and click on the top Events button in the sidebar and you'll see you have multiple events with the same name - like so:






The issue, when you import new pics using the "Event Name" at the bottom...



This does not import pics into an existing event with the same name. It creates a new event with that name.





There are a couple of ways to solve the immediate issue. In iPhoto, with Events highlighted in the sidebar, select all the events with the same name, then right click on one of them and select "Merge Events".



You can also drag and drop one event onto another to merge them.

That should take care of the immediate issue. I'm not really sure how or if there is a way to import pics into an existing event. If there is, I didn't figure it out in the few minutes I played with it. However, I do not use events. I use Projects and Albums and I import pics into Albums and move Albums into Projects. With Albums, you can create a new Album prior to importing and then drag and drop all the pics you want into it to import them.

To continue using Events, can only suggest after importing some pics that you want in an existing event - click the Events link in the sidebar and make sure you merge the new one into the existing.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
Bob,

That's the thing, when I click events they only show up once not like in your example. iTunes is still showing multiple events for same thing. It's weird.
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 25,192
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
Am assuming you're running iLife '11?

Quit iPhoto.

Next couple of things I'd try would be Repair Permissions - don't think this one will do it, but I've seen it fix some pretty strange things.

After that, I'd try dumping the iPhoto plist files. They'll be in your home folder / Library / Preferences... You'll have 2 or 3 of them... com.apple.iPhoto... Quit iPhoto, move those files to the desktop. Open it back up and just browse a little. Then give it a shot.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
Ok. I give that a shot...you're right the permissions thing was a no-go
QUOTE Thanks
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
Quote:
Originally Posted by bobtomay View Post
Am assuming you're running iLife '11?

Quit iPhoto.

Next couple of things I'd try would be Repair Permissions - don't think this one will do it, but I've seen it fix some pretty strange things.

After that, I'd try dumping the iPhoto plist files. They'll be in your home folder / Library / Preferences... You'll have 2 or 3 of them... com.apple.iPhoto... Quit iPhoto, move those files to the desktop. Open it back up and just browse a little. Then give it a shot.
UPDATE 2: Well it works until you re-sync or re-start the Macbook...looks like Apple is going to have to fix this one.

UPDATE: Re-tried your steps and rebooted the computer and now there are only the events in iTunes under "photos tab"...I'm going to sync and see what happens.


Yes... iLife 11...I pulled the 2 plist files to the desktop and re-opened iPhoto...iPhoto tried to start a new library so I closed iPhoto and opened using the alt+left click on iPhoto to boot from my default library with all the pictures...I closed iPhoto and opened iTunes with the iPad 2 connected and the problem still exists...do you happen to have any other ideas Bob?

thanks
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 25,192
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
From the way you're describing it, def sounds like a bug introduced. It could be in iPhoto or it could be in the way iTunes reads the iPhoto plist file.

Without iPhoto '11 here, puts me at a standstill. You could do some experimenting - find out which of the plist files is causing it by removing only 1 at a time. Does it show properly in iTunes through 2 syncs if you do not open iPhoto in between (which should be what recreates the pref file). Does the sync show properly only when there is no pref file, or will it work one time with a new pref file and not the second time... Opening and not opening iPhoto in between... Creating copies of the pref file from when it works to when it doesn't and comparing the 2 of them.

e.g. A bunch of work. Sorta depends on how geeky you want to be and how much it bothers you or just live with it until apple fixes it. I'd def report the bug to them.

Have you got any iPhoto plugins? Another thing to look at.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
thanks man, I have no plug-ins...how do I report it to Apple officially? They had to do a clean install last night of the OS but the computer when crazy.
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 25,192
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
Apple - Mac OS X - Feedback

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
Gary86

 
Gary86's Avatar
 
Member Since: Jan 31, 2010
Location: Honolulu, Hawaii
Posts: 298
Gary86 is on a distinguished road
Mac Specs: Early 2010 13" MBP; Late 2010 13" MBA

Gary86 is offline
Well my Air went nuts last night and Apple had to do a clean OS install...good thing is when I re-installed iLife 11...iPhoto was on 9.1 so I'm not updating to 9.1.2
Attached Images
File Type: png Screen shot 2011-04-30 at 12.33.59 PM.png (497.0 KB, 7 views)
QUOTE Thanks

Post Reply New Thread Subscribe


« I Lost My Progress In Pages!!!! | E-Mail Clients (For Mac) »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Share multiple iTunes libraries on 2 Macs? Peakoverload OS X - Apps and Games 2 03-21-2011 01:10 PM
iphone 3gs wont sync to iTunes 10.1 - can't solve the problem. mdro0 iPhone Hardware and Accessories 4 01-16-2011 11:27 AM
Sync vs. backup...different iTunes computer lokerd iOS and Apps 0 04-30-2010 04:29 AM
Locate iPhotos and Itunes newMacbookUser OS X - Operating System 1 09-15-2007 05:52 AM
display multiple artwork in itunes nick_harambee iPod Hardware and Accessories 0 02-24-2007 08:54 AM

All times are GMT -4. The time now is 10:11 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?