Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   Building Hydra from source code (http://www.mac-forums.com/forums/os-x-apps-games/234597-building-hydra-source-code.html)

archos4 04-05-2011 03:20 PM

Building Hydra from source code
 
Firstly, could I just say I'm not sure whether I've posted this in the right section-not sure if it should go in Darwin and development or something, so sorry if I've put it in the wrong place.

I'm new to compiling the software from source files. So I was wondering if someone can point out the (probably) glaringly obvious here which I can't see. This is basically what I've typed into Terminal and what I see now.


Last login: Tue Apr 5 19:11:20 on ttys001
james-pc:~ James$ sudo port install hydra
Password:
---> Computing dependencies for hydra
---> Dependencies to be installed: libssh01 openssl zlib
---> Fetching zlib
---> Attempting to fetch zlib-1.2.5.tar.bz2 from zlib Home Site
---> Attempting to fetch zlib-1.2.5.tar.bz2 from Index of /zlib
---> Attempting to fetch zlib-1.2.5.tar.bz2 from Index of http://mirror.aarnet.edu.au/pub/macports/mpdistfiles/zlib/ - Updated daily
---> Verifying checksum(s) for zlib
---> Extracting zlib
---> Applying patches to zlib
---> Configuring zlib
---> Building zlib
---> Staging zlib into destroot
---> Installing zlib @1.2.5_0
---> Activating zlib @1.2.5_0
---> Cleaning zlib
---> Fetching openssl
---> Attempting to fetch openssl-1.0.0d.tar.gz from Index of /openssl
---> Verifying checksum(s) for openssl
---> Extracting openssl
---> Applying patches to openssl
---> Configuring openssl
---> Building openssl
---> Staging openssl into destroot
---> Installing openssl @1.0.0d_0
---> Activating openssl @1.0.0d_0
---> Cleaning openssl
---> Fetching libssh01
---> Attempting to fetch libssh-0.11.tgz from Index of /libssh
---> Verifying checksum(s) for libssh01
---> Extracting libssh01
---> Applying patches to libssh01
---> Configuring libssh01
---> Building libssh01
---> Staging libssh01 into destroot
---> Installing libssh01 @0.11_1
---> Activating libssh01 @0.11_1
---> Cleaning libssh01
---> Fetching hydra
---> Attempting to fetch hydra-5.4-src.tar.gz from Index of /hydra
---> Verifying checksum(s) for hydra
---> Extracting hydra
---> Applying patches to hydra
---> Configuring hydra
---> Building hydra
---> Staging hydra into destroot
---> Installing hydra @5.4_3
---> Activating hydra @5.4_3
---> Cleaning hydra
james-pc:~ James$

I may be wrong, but it seems like I've built it. But I don't know where the Hydra program is installed now. (At least I think that's the problem I've got.) Can anyone make sense of where the application is from that code? Thanks for any help/advice in advance

vansmith 04-05-2011 03:28 PM

Everything worked as planned during that build. So yes, everything has been installed - you'd see a nasty and likely indecipherable error otherwise.

Start basic - try to run "hydra" by simply typing the name and hitting enter. Otherwise, type the first few letter and push tab to see if Bash autocompletes the name for you (the name may be different and may be something like "hydra-bin").

archos4 04-05-2011 03:49 PM

I tried typing hydra and got this.


james-pc:~ James$ hydra
Hydra v5.4 [http://www.thc.org] (c) 2006 by van Hauser / THC <vh@thc.org>

Syntax: hydra [[[-l LOGIN|-L FILE] [-p PASS|-P FILE]] | [-C FILE]] [-e ns]
[-o FILE] [-t TASKS] [-M FILE [-T TASKS]] [-w TIME] [-f] [-s PORT] [-S] [-vV]
server service [OPT]

Options:
-R restore a previous aborted/crashed session
-S connect via SSL
-s PORT if the service is on a different default port, define it here
-l LOGIN or -L FILE login with LOGIN name, or load several logins from FILE
-p PASS or -P FILE try password PASS, or load several passwords from FILE
-e ns additional checks, "n" for null password, "s" try login as pass
-C FILE colon seperated "login:pass" format, instead of -L/-P options
-M FILE server list for parallel attacks, one entry per line
-o FILE write found login/password pairs to FILE instead of stdout
-f exit after the first found login/password pair (per host if -M)
-t TASKS run TASKS number of connects in parallel (default: 16)
-w TIME defines the max wait time in seconds for responses (default: 30)
-v / -V verbose mode / show login+pass combination for each attempt
server the target server (use either this OR the -M option)
service the service to crack. Supported protocols: telnet ftp pop3[-ntlm] imap[-ntlm] smb smbnt http[s]-{head|get} http-{get|post}-form http-proxy cisco cisco-enable vnc ldap2 ldap3 mssql mysql oracle-listener postgres nntp socks5 rexec rlogin pcnfs snmp rsh cvs svn icq sapr3 ssh2 smtp-auth[-ntlm] pcanywhere teamspeak sip vmauthd
OPT some service modules need special input (see README!)

Use HYDRA_PROXY_HTTP/HYDRA_PROXY_CONNECT and HYDRA_PROXY_AUTH env for a proxy.
Hydra is a tool to guess/crack valid login/password pairs - use allowed only
for legal purposes! If used commercially, tool name, version and web address
must be mentioned in the report. Find the newest version at #!/bin/the hacker's choice - THC

Forgive me if this is a silly idea, but I thought there'd be some actual aqua application with a GUI. I wasn't expecting to be running this from the command line. The hydra website displays a Windows program with a simple user interface. I thought these build commands would build a Mac version of that... Is that not possible to do? I can't seem to find clear advice on the developer's website or by a google search.

vansmith 04-05-2011 04:26 PM

The UI on the website is for a GTK application, commonly used on Linux and other *nix OSes (not including OS X although you can run GTK apps in OS X). Take a look at the README for usage instructions.

Note their disclaimer (and I'm not accusing you of anything here): use it for legal purposes only. Be careful what you do with that tool.

archos4 04-05-2011 04:40 PM

OK, that's made everything clear. I've re-read the readme and I understand what you're saying. Thank you very much. :)


All times are GMT -4. The time now is 06:47 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.