Hello there,
In the past I have had great joy with data rescue II as it recovers files with ease.

Today, I was in a panic trying to recover .jpgs and Qts from an SD card that I'd corrupted. Data rescue started a 'deep scan' successfully, would get part the way through and all of a sudden the OS is telling me that I have 'removed the device' prior to unmounting. And thus suspending the scan for good.

Ah, ok, well, I hadn't touched the SD card during the scan

I have tried several 'deep scans' and attempted to 'clone' the problem drive but everytime it gets 365mb through the 7.4GB scan the drive 'self-removes' and you get the large OS notification, with a big red sign, telling you all about 'device removal'

1.) Is this a problem with the OS or Data rescue III?

2.) Is the OS/app having a problem with the fact it is an SD card; (mounted via a USB adapter--- I have tried SD card directly---same result.) and not a hard disk.

3.) Is there anyway to stop OS from thinking that the device has been pulled, when actually it is left quite happy in its USB port.

If I can keep the card and the OS happy and mounted during the scan I feel the 'deep scan' could potentially finish and therefore solve my problem, I just danne know how??

Ahhhh, I want my files back

Any suggestions would be immense!!
Cheers in advance.