Firefox is telling me I need to update my plug-ins as the attached image below shows:



Is it ok to just update them all or do I need to check whether there might be compatibility issues with my older G4 iBook (Tiger 10.4.11) once updated?

Thanks.