I can't disable smooth scrolling feature in System Preferences/Appearance after updating from Leopard to Snow Leopard. Any idea how to do it?

Ticking or unticking it doesn't produce any results.

EDIT: Found the solution. It's nothing to do with smooth scrolling. It's the scroll without inertia that needs to be selected in the trackpad options.