New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

iMovie 11 and Virtual Memory


Post Reply New Thread Subscribe

 
Thread Tools
LinuxElf

 
Member Since: Nov 21, 2010
Posts: 5
LinuxElf is on a distinguished road

LinuxElf is offline
I am shooting high school basketball video with two Sony HD cameras:
1 camera follows the action on the court, the other stays on the clock.

I then use iMovie 11 to superimpose the clock video using Picture-in-Picture onto the game footage.

Both cameras shooting highest HD at 30 fps.

Last basketball season, I was using iMovie 09 on a MacBook Pro, Intel Core 2 Duo, 4GB RAM, 256GB SSD. I would import Video 1, import Video 2, superimpose Picture-in-Picture, share to iDVD, burn videos, no worries.

This basketball season, I am using iMovie 11 on a Mac Pro, dual Intel-6-core, 16GB RAM, 512GB SSD. I am having some kind of problem with memory (I think).

I boot my Mac Pro. I import the 1-hour Video 1, it takes 11 minutes. If I now import the 1-hour Video 2 (with no reboot), it takes about 30 minutes.

If I boot my Mac Pro, import 1-hour Video 1 in 11 minutes, then reboot the Mac Pro again, the 1-hour Video 2 takes 11 minutes.

When I share to iDVD to burn standard DVDs, if I reboot, it takes about 30 minutes. If I do not reboot, it takes about 2 hours.

When I export to Quicktime at 1920x1080 to burn on a Blu-Ray disc using Toast without a reboot, the export fails 4 times out of 5. If I reboot before exporting to Quicktime, the export always works.

On my MacBook Pro, using iMovie 09, of course all the times were slower because of fewer/slower cores, but I was never rebooting constantly.

So, as I write this, iMovie 11 on the Mac Pro is working away to export a Quicktime so I can burn it to Blu-Ray in Toast.

I have 16GB total RAM:
Free: 13.2GB
Wired: 824.5MB
Active: 1.7GB
Inactive: 281.7MB
Used: 2.7GB
VM Size: 118.5GB
Page Ins: 152.8MB
Page outs: 204KB
Swap Used: 344KB

Using about 5 cores for exporting the Quicktime (502.1%).

In another thread, I saw someone recommend using Onyx to in between imports or exports as a way to clean up memory.

But, that same thread also talked about how the poster's VM would get up to 4GB and that was when he used Onyx.

Is my VM size unusual? I cannot seem to find definitive information on the VM size and whether something is not right on the Mac Pro, or whether this is normal.

I hope someone in this forum can help. In the meantime, I just reboot my Mac Pro in between every import or export, which (to me!) is a little crazy.

Thanks much for any help or advice. If I can provide other details, please let me know.

LinuxElf
QUOTE Thanks
LinuxElf

 
Member Since: Nov 21, 2010
Posts: 5
LinuxElf is on a distinguished road

LinuxElf is offline
Additional information:

This is all being done on the internal SSD. 512GB total space.

When I started my latest two-video import, I had 460GB of free space.

After importing two videos and generating Quicktime video for Toast to burn a Blu-Ray, plus leaving the last game's Quicktime on the SSD, I now have 199.5GB free as I burn standard DVDs. (I get two Quicktime videos per Blu-Ray, so every other game I have an extra Quicktime sitting on the internal SSD taking up about 30GB space.)

After I have finished burning DVDs, within iMovie, I move the iMovie Project and associated video files from the internal SSD to a DROBO external drive unit.

So, once I am done with today's work, and after all the files including Quicktimes are moved to the DROBO, I expect to have over 480GB free.

I should have included this in original post.

LinuxElf
QUOTE Thanks

Post Reply New Thread Subscribe


« Accidently Deleted my TextEdit ! | itunes help »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 02:36 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?